Solved Device notifier uses showFoto instead of Dolphin when opening with file manager

rawthey

Member

Thanks: 5
Messages: 43

#1
When I insert a usb memory stick and mount it with the device notifier I'm presented with three options, 'Open with File Manager', 'Download Photos with digiKam' and 'Download Photos with Gwenview'.

When I click on 'Open with File Manager' it opens showFoto instead of Dolphin. This happens irrespective of whether there any images on the device or not - even for a freshly formatted empty memory stick. The other two options do open digiKam and Gwenview as expected.

Device manager settings shows the command for opening with file manager as 'kioclient exec %25f. None of the media manager settings appear to refer to showFoto.

snap-01.png snap-02.png

How can I restore the correct behaviour.
 

Snurg

Aspiring Daemon

Thanks: 326
Messages: 794

#2
I guess this is because of an important shortcoming of the FreeDesktop spec.
The thing is that there may be multiple program associations but there is no defined way which one should be selected by default.
Thus it is a random matter which one of the programs in the category "FileManagers" will get picked.
You have two choices, either remove the file associations of a particular program (i.e. in your case showFoto), or to find where you specify which program files of that sort should be opened.
I know that there is some setting somewhere in KDE, but forgot where.
So you know the basic cause of your problem. I cannot help you further, as I do not use KDE, sorry.
 
OP
OP
R

rawthey

Member

Thanks: 5
Messages: 43

#3
You have two choices, either remove the file associations of a particular program (i.e. in your case showFoto), or to find where you specify which program files of that sort should be opened.
I know that there is some setting somewhere in KDE, but forgot where.
Thanks, that got me looking in the right direction. After trawling through file associations in the system settings I found showFoto at the top of the list under inode -> directory. Deleting showFoto from the list got things sorted.
 
Top