Xfce desktop parameters not saved about wallpapers [11p2]

CiotBSD

New Member

Reaction score: 3
Messages: 18

Hi, with my fresh installation about FreeBSD 11p2, and xfce...

When I try to change wallpaper folder in the desktop parameters
Menu 'parameters' > 'Desktop', I change folder by a folder named 'Wallpapers' into folder 'Images' in my home ... but can not saving my choice !
(~/Images/Wallpapers)
All files are into jpeg format, or png.

When i reopen the desktop settings, it's defaults images into, and not my choice

 
Last edited:

olivierd

Active Member

Reaction score: 80
Messages: 128

Hi, with my fresh installation about FreeBSD 11p2, and xfce...

When I try to change wallpaper folder in the desktop parameters
Menu 'parameters' > 'Desktop', I change folder by a folder named 'Wallpapers' into folder 'Images' in my home ... but can not saving my choice !
(~/Images/Wallpapers)
All files are into jpeg format, or png.

When i reopen the desktop settings, it's defaults images into, and not my choice

Can you launch,
xfdesktop-settings
in console, and display any messages?

Then result of xfconf-query -c xfce4-desktop -l
 
OP
CiotBSD

CiotBSD

New Member

Reaction score: 3
Messages: 18

Code:
% xfdesktop-settings

(xfdesktop-settings:1056): GVFS-RemoteVolumeMonitor-WARNING **: remote volume monitor with dbus name org.gtk.vfs.HalVolumeMonitor is not supported
fstab: /etc/fstab:6: Inappropriate file type or format

(xfdesktop-settings:1056): GVFS-RemoteVolumeMonitor-WARNING **: remote volume monitor with dbus name org.gtk.vfs.GPhoto2VolumeMonitor is not supported

Code:
% xfconf-query -c xfce4-desktop -l
/backdrop/screen0/monitoreDP1/workspace0/backdrop-cycle-enable
/backdrop/screen0/monitoreDP1/workspace0/backdrop-cycle-random-order
/backdrop/screen0/monitoreDP1/workspace0/backdrop-cycle-timer
/backdrop/screen0/monitoreDP1/workspace0/color-style
/backdrop/screen0/monitoreDP1/workspace0/image-style
/backdrop/screen0/monitoreDP1/workspace0/last-image
/backdrop/screen0/monitoreDP1/workspace1/color-style
/backdrop/screen0/monitoreDP1/workspace1/image-style
/backdrop/screen0/monitoreDP1/workspace1/last-image
/backdrop/screen0/monitoreDP1/workspace2/color-style
/backdrop/screen0/monitoreDP1/workspace2/image-style
/backdrop/screen0/monitoreDP1/workspace2/last-image
/backdrop/screen0/monitoreDP1/workspace3/color-style
/backdrop/screen0/monitoreDP1/workspace3/image-style
/backdrop/screen0/monitoreDP1/workspace3/last-image
/backdrop/single-workspace-mode
/backdrop/single-workspace-number
/desktop-icons/icon-size
/desktop-icons/single-click
/desktop-icons/tooltip-size
/last/window-height
/last/window-width
 

olivierd

Active Member

Reaction score: 80
Messages: 128

No more ideas?!

I have just tested, and backdrop cycle is working. At first I thought that it's monitoring problem.

Try to reset your changes:

Code:
xfconf-query -c xfce4-desktop -p / -rR

Then re-launch xfdesktop-settings, without enabled random number.

I know, there are changes in upstream repository, which fix backdrop settings. But it's not easy to track down, because new hidden option was introduced (for animation files).
 
Top