Solved dependency of pecl-imagick-3.4.1

I'm trying to install pecl-imagick (3.4.1) and pecl-pdflib-3.0.4 using pkg and they both require php56. I've php55 (php55-5.5.38 to be exact) installed on my system (FreeBSD 10.3). I've checked and it says php 5.2.0 or newer required. and for pecl-imagick says php 5.4.0 or newer required. I'm confused. If php5.2.0 is enough why it needs php5.6? Will it cause a problem? Or how shoud I install those packages to run with php55. Thanks
Hi. PHP 5.6 has been the default PHP version since last year. The version is hard-coded at buildtime so if you wish to use an older version for dependencies you would have to use the /etc/make.conf override and compile the port locally.

However, I am just showing that for completeness as you should update to PHP 5.6 anyway as PHP 5.5 went EOL last month and will be removed soon (