Delay in prompt appearing

I have a clean install of 11.0 on a machine at my house that I'm connecting to using ssh (from iTerm in OS X). I've been having a problem where there is a delay in the prompt appearing after I exit certain applications.

I've had this problem with neovim and vim. What will happen is that I will enter vim<CR> :q<CR>, and sometimes I will see this, with no delay:

username@hostname:~ % nvim
username@hostname:~ %

But other times, the blank prompt will not appear immediately. Sometimes it will take 1-2 seconds, other times it will take about 10 seconds, and sometimes it will not appear until I press another key.

There is no delay when I use vi or less, which don't clear the screen on exit. There is also never a delay if I run neovim or vim under truss. I have the problem when my shell is sh, csh, or tcsh (using chsh and logging in again, not just in a nested shell). I also have the problem when using my normal account and as root.

As I mentioned, this is a clean install of the OS. The first thing I did was install neovim. I'm yet to update an config files or install other programs. I've tried installing with pkg and ports, but same problem in both cases.

Thanks in advance for any help.
Please upgrade to 11.1 at your earliest convenience, FreeBSD 11.0 will be EoL in a month or so.

The issue you describe sounds a lot like a DNS issue, most notability the ability (or lack thereof) of reverse resolving the IP address back to the hostname. If you can't fix DNS try adding the short and full hostname with the IP address to your /etc/hosts file.