deinstall fails. corrupt db?

komyer

New Member


Messages: 2

I started a portupgrade of xorg, yesterday, after installing 7.1 release from cdrom about a week ago. However, portupgrade would stop with uninstall errors. I'd go into the ports directory /usr/ports/x11-drivers/xf86-video-r128 and try to make uninstall, but get segmentation fault. Tried pkgdb -F, failed; tried rm /var/db/pkgdb.db, pkgdb -fu, failed. Started looking around, and found about 6 ports with a null dependency:

pkg_info -v xfce-4\*
..cut..
Dependency: dbus-glib-0.78
dependency origin: devel/dbus-glib
Dependency: (null)
Comment: @unexec rm -f /usr/local/etc/gdm/Sessions/XFce4
Comment: @dirrmtry /usr/local/etc/gdm/Sessions
Comment: @dirrmtry /usr/local/etc/gdm
..cut..

I "fixed" all but xfce-4 by pkg_add -f [package from cdrom], then was able to deinstall and finish portupgrade.
However I installed xfce-4 from internet and don't have the same version to install without deinstall first.
Is there a good way to fix this?
 

jb_fvwm2

Daemon

Reaction score: 191
Messages: 1,734

pkg_delete -f /var/db/pkg/xfce- (xfce4-?) -NUMBER
should do a deinstall. You can then install
from the /xfce/ or /xfce4/ maybe, if that was your
question
 
OP
K

komyer

New Member


Messages: 2

pkg_delete seg faults, still.

> pkg_info -E xfce-4\*
xfce-4.4.3
> sudo pkg_delete -f /var/db/pkg/xfce-4.4.3
Password:
Segmentation fault
> sudo pkg_delete -f xfce-4.4.3
Segmentation fault
>

It seems to me, that pkg_delete doesn't know how to deal with a null dependency. Which it souldn't have to. I may have somehow incorrectly deleted the dependency with pkgdb -F at some point. But don't know which or when.
Though it seems pkg_delete doesn't use /var/db/pkg/pkgdb.db for dependencies. That is part of the portupgrade package. No matter how i've tried rebuilding it, pkg_info still shows that null Dependency in xfce-4.4.3
 
Top