default local fonts

I am russian user, so, I have trouble with localisation. As I understand, there is default local font, that is used for every font, that does not have symbols for my localisation.

The question is: how can I change this default font?
 
Thank you, but I have already searched through these resources many times, and I still don`t know, what to do.

Most of all fonts (including default sans!) look (as they should) diffirent for english letters and symbols, but the russian letters are similar (and - if not, I would not mind this trouble at all - they look ugly on my screen). That is my trouble. As I understand, there should be a file, where I can set this "similar" default font, shouldn`t it?
 
do you have problem only with fonts?


try installing this
x11-fonts/webfonts

After i installed them, Russian sites in firefox are way more readable then they used to be
 
Hi,

I can speak a little Russian, and I know how to solve this problem.

You need DejaVu font, and specify your app use it, and this is my .fonts.conf, I always use it config my font.
Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- ~/.fonts.conf for per-user font configuration -->
<fontconfig>

<alias>
<family>serif</family>
<prefer>
<family>DejaVu Sans</family>
<family>AR PL KaitiM GB</family>
<family>AR PL KaitiM Big5</family>
<family>AR PL SungtiL GB</family>
<family>AR PL Mingti2L Big5</family>
</prefer>
</alias>

<alias>
<family>sans-serif</family>
<prefer>
<family>DejaVu Sans Serif</family>
<family>AR PL KaitiM GB</family>
<family>AR PL KaitiM Big5</family>
<family>AR PL SungtiL GB</family>
<family>AR PL Mingti2L Big5</family>
</prefer>
</alias>

<alias>
<family>monospace</family>
<prefer>
<family>DejaVu Sans Mono</family>
<family>AR PL KaitiM GB</family>
<family>AR PL KaitiM Big5</family>
<family>AR PL SungtiL GB</family>
<family>AR PL Mingti2L Big5</family>
</prefer>
</alias>

</fontconfig>

But I want to know how to input Russian with my English keyboard?
 

Attachments

  • Untitled.png
    Untitled.png
    13.3 KB · Views: 483
Well, my boss uses american notebook without russian letters quite well - as I did, when I worked in Germany. It is very easy to remember, where the letters must be (well, may be it is easy for me, after piano classes, but there is a school of "blind input" - or how do you call it in english?). Anyway, if you want, I can send you russian layout, and you may write letters on your keyboard. In Russia, it is able to buy stickers with russian letters. Maybe, I`ll send you a set by mail?
 
HiDE said:

You can touch .fonts.conf in your home, and never edit your system configuration_file for some user's need.

Generally, there are too many users on the system, everyone has his own configuration, and another reason is when you upgrade your system, the system range configuration_file maybe overwrited.
 
Well, it`s again: it changed only english letters. Russian letters are defined somewhere esle, and devined very strictly.
 
I am a gnome user and use gdm login the system, for test I select russian, it is work for me.

The .fonts.conf can help you to sort fonts sequence, but you also need specify your application use "dejavu fonts".

These picture is my setting.
 

Attachments

  • Screenshot-Настройки внешнего вида.png
    Screenshot-Настройки внешнего вида.png
    79.7 KB · Views: 485
  • Screenshot-Подробности отрисовки шрифтов.jpg
    Screenshot-Подробности отрисовки шрифтов.jpg
    18.1 KB · Views: 430
  • Screenshot-Шрифты.png
    Screenshot-Шрифты.png
    92.9 KB · Views: 533
  • Screenshot-Параметры.jpg
    Screenshot-Параметры.jpg
    13.6 KB · Views: 421
  • Screenshot-The FreeBSD Forums - Powered by vBulletin.png
    Screenshot-The FreeBSD Forums - Powered by vBulletin.png
    79.4 KB · Views: 454
  1. install dejavu font
  2. correctly specify your screen's dpi
  3. use .fonts.conf to sort system font's sequence
  4. specify your system use dejavu font
 
Slesarev said:
Well, my boss uses american notebook without russian letters quite well - as I did, when I worked in Germany. It is very easy to remember, where the letters must be (well, may be it is easy for me, after piano classes, but there is a school of "blind input" - or how do you call it in english?). Anyway, if you want, I can send you russian layout, and you may write letters on your keyboard. In Russia, it is able to buy stickers with russian letters. Maybe, I`ll send you a set by mail?

no need to bother, you can use russian phonetic layout

i use fvwm as my window manager, and i have implemented switching languages in menu

here's command i use to switch to ru
setxkbmap ru phonetic
no that after you use it, you can't type any commands, because no latin letters.
either configure xorg.conf file or find an other way to switch back to English
 
Well, you can set the phonetic layout through visual utilities of GNOME, in Keyboard section. But - IMHO - the default russian layout is much more useful, as it is optimised by placing most usable letters under your hands.
 
ye, but if you don't know original Russian layout...
I have it typed on keyboard, and it still takes to long to find right character.

If you don't write Russian every day (write rarely), i suggest phonetic.
 
Oh boy, why it's so hard? I type in 4 languages including Russian with 10 blindly.
First I learned English keyboard (lot's of programs to help). Then when I needed a new language I typed all characters in sequence (3 rows) on the top of the sheet and typed looking at it. After short time I remembered all the positions. My zyat', a scientist, glues Russian stickers but he types 10 times slower.
To get help in Russian try http://www.truebsd.org/forum
They just helped me to correct Cyrillic fonts :)
 
Back
Top