ZFS data error 0x188 of the pool causes OS to reboot

Code:
panic: solaris assert: rs == NULL, file: /usr/src/sys/cddl/contribts/common/fs/zfs/range_tree.c, line: 186
cpuid = 0

this happens when the pool is mounted or imported
I did a scrub by disconnecting the drives at boot and reconnecting them after boot to prevent the auto mount of the pool, the scrub failed to repair this permanent error that does not point to any file and only to the pool name itself

the error 0x188 was caused by a deletion operation that was interrupted by a reboot of the system, it's not known why the system rebooted while deleting the files and it's not known if the deletion itself is what caused the system to reboot

freebsd is version 11, the pool was created with default settings under version 10.2

I've tried to mount the filesystem on freeBSD 10 from the DVD but it had the same error and rebooted

on freebsd 12 the error is different: attached
seems to indicate a problem with the ZIL, but how else to fix it if scrub doesn't work ?

I did a full scrub, it didn't help, then did a clear also didn't help, then did a clear -F, still didn't fixed, finished running another scrub after the clear -F, this time it indicates that it fixed 272K but the error is still there, the mount failed again with the same error

-o readonly=on also crashes the system
did a export/import, same thing, system crashed

i am out of any more ideas, is there anything other than scrub that I can run to fix it ?

OK so I looked around to find some solutions to this problem and came across a project ZFS on Linux, installed Ubuntu Server 17 and got the zfsutils-linux package, imported the array and mounted it, strangely enough got the same error but the OS didn't crash and am able to access the filesystem
 

Attachments

  • freebsd12.jpg
    freebsd12.jpg
    1.7 MB · Views: 342
Last edited:
Back
Top