CUPS printing

zeta_immersion

Member


Messages: 23

I hope this goes into networking.

I have Cups on FreeBSD 7 release, and i am trying to print on a brother(usb) on a winXp machine (192.192.1.100) but i do not seem to make heads/tales of the cups sending the job to my winxp machine ..


i have tried
//mywinxp/myprinter
//mywinxp/printers/myprinter
//mywinxp/printer and faxes/myprinter

http://mywinxp/ ...

can anyone help? thanks
 

Djn

Well-Known Member

Reaction score: 67
Messages: 392

Edit: This is why I should never post after three in the night. Printing to and printing from XP are really quite different things...

Original post left for the curious.

Try adding a new network printer, and use "http://1.2.3.4:631/printers/myprinter" as the URL, replacing 1.2.3.4 with the IP of your server. In the XP network printer window, use the last of the three alternatives, the one where the text field is labeled "URL". (In my norwegian XP, it's called something like "Connect to a printer on the internet or a home-/office-network").

In order to use \\servername\printername, you will have to set up samba on your server. It's not required to print, since the above should work and only requires CUPS, but it does make things slightly more elegant.
 
OP
Z

zeta_immersion

Member


Messages: 23

I have installed Samba, and uncommented swat from inetd, also swat 901 from hosts.allow and when i go to http://localhost:901 is not working...

i have tried lynx localhost:631 (cups) and it works
but lynx localhost:901 is not working ...

smb starts up fine, but inetd does not seem to want to start swat, am i missing something?
 

tingo

Daemon

Reaction score: 549
Messages: 2,403

A few questions:
- is the printer connected to the WinXP machine?
- is sharing of this printer enabled on said WinXP machine?
 
OP
Z

zeta_immersion

Member


Messages: 23

yes, the printer is enabled on the xp machine, i have another xp machine that can access the same printer no problem. I am surprised at this (note that cups sees my networked printer fine, it just has problems with the printer on the xp pro machine)
 

tingo

Daemon

Reaction score: 549
Messages: 2,403

Well then you will just have to configure CUPS to print to a remote printer. A windows printer.
 
Top