• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Ctrl-S sequence while using "cu"

Nicola Mingotti

Active Member

Thanks: 88
Messages: 184

#26
I was able to find a solid solution the the Ctrl-S problem in "cu".
This the procedure, tested in FreeBSD-11.1 calling "cu" to connect to an
OpenBSD6.1 running in an Alix 2d13 and a Debian running on a
BeagleBone Black.

The point is to set correctly parameters "ixon" and "ixoff"
from the shell in FreeBSD, that is in the shell running "cu" program.

I found in depth coverage for this material in the book:
Stevens, "Advanced Programming in the Unix Environment".

First of all, understand which are the settings of your terminal using:
Code:
$> stty -a
Don't user "stty" without "-a", its output will only confuse things.

In the "iflags" output line you must see "-ixon" and "-ixoff".
If you don't see that, use these commands to remove those options.
Code:
$> stty -ixon
$> stty -ixoff
Try again "stty -a", once you will read "-ixon" and "-ixoff"
then those ugly Ctrl-S and Cltr-Q will be disabled and you
can use "mg" and "emacs" from "cu" !

Bye
Nicola
 
Top