Solved Crashplan no longer runs

I recently updated the Crashplan port to the latest version on my system (it runs in its own jail) and noticed that it is no longer running

I suspect that the reason it isn’t working is due to the changes to the Java dependencies made recently. Before the last update java/linux-sun-jre17 was used as the java dependency, now java/linux-oracle-jdk18 is used.

Not seeing anything in the Crashplan logs but I am not sure where else to look

Thanks in advance.
It sounds like it's failing very early on. Either engine_error.log or engine_output.log (in /var/log/crashplan) might have relevant information. Have you checked there?
It seems there's a nasty bug in the startup scripts that's causing engine_*.log to land in the root directory. Can you check if that's the case on your system? Any early startup errors would be logged there.
Here is the output:
$ cat engine_error.log
nice: illegal option -- D
usage: nice [-n increment] utility [argument ...]

and engine_output.log is empty.
That seems to have fixed it. But I will do more tests to confirm it is working tomorrow evening when I have more time.

Well it works for a while then it stops. It looks like it is looking for /bin/bash which of course does not exist. Symlinking /usr/local/bin/bash to /bin/bash solves the issue.

Other than that it appears to be working properly.
Any chance of getting the port updated so users don't have to jump through these hooks.

I think the issue with /bin/bash has to due with Crashplan updating itself. The port installs and run without issue, but after a while it updates itself and then starts looking for /bin/bash which prevents it from running correctly.
The issue with bash seems like it could be a problem. I don't think that throwing a symlink in /bin from a port would be very well received.

I haven't seen this issue on my machine, though. It sounds a bit odd, since a Linux binary forking a script should end up executing /compat/linux/bin/bash. As a sanity check, would you mind checking if that file exists in your system?
Sorry I missed your request. The file does exist.

Ya putting a symlink in /bin would probably not go over well, and it wouldn't even work on my system since I am running CrashPlan in a ezjail and /bin is mounted read only. Perhaps getting the port to display a message on install that symlinking bash to /bin is a helpful troubleshooting step if the port stops working when crashplan auto updates.

The good news is the recent update to the port (CrashPlan 4.7) seems to have fixed the issue.
Hmm, looks like there was a minor update to CrashPlan and again we need to symlink bash to /bin to get CrashPlan working again. Not a big deal, but this might help other with the same issue