Solved Control skype traffic by squid

Hi guys , I have been writing a ACL rules for flitering skype traffic for a while .
acl numeric_IPs dstdom_regex ^(([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+)|(\[([0-9af]+)?:([0-9af:]+)?:([0-9af]+)?\])):443
acl Skype_UA browser ^skype
acl validUserAgent browser \S+
acl skypenet dstdomain

#IP list that allow access to skype
acl user_to_im src "/usr/local/etc/squid/skyper"

#Allow access to skype
http_access allow CONNECT user_to_im numeric_IPS
http_access allow CONNECT user_to_im Skype_UA
http_access allow CONNECT user_to_im !validUserAgent
http_access allow CONNECT user_to_im skypenet
I think it should be forcing skype passed by port 443 and 80 ( I allow 80 and 443 in squid.conf) and it is working good for a long time.
But in the recent , the skype have release a new version , after that , some client can not access skype by squid proxy server ...:(
I assume skype have change the login method or login page that cause this problem.
Any suggestion will be grateful,thanks
Hi , I using Wireshark to sniffer packet , and I noticed that a new domain "" exist !
So, I add it in "acl skypenet dstdomain" .And one more thing , update your windows IE 8 to IE 11 , otherwise it will not support "HTTP Proxy" setting !
Hi guys
Skype has recently changed their domain name.
The following names are what I have observed.
Hope this may be helpful