compiz-fusion

soylentgreen

Member

Reaction score: 1
Messages: 39

I'm confused. Following the handbook here:
http://www.freebsd.org/doc/en/articles/compiz-fusion/index.html

I use the 'minimal' distribution when I install FreeBSD systems.

1) I was under the impression that compiz-fusion was separate from gnome / kde and you didn't need them installed. So I installed the
Code:
X11-wm/compiz-fusion
and realized there was no xorg. I then installed xorg from ports so I could edit the xorg.conf file and added the selections found here:
http://www.freebsd.org/doc/en/articles/compiz-fusion/xorg-configuration.html
As I read through the next page of the handbook for configuring compiz-fusion, it seems that you need to have something already configured for X before you can have compiz-fusion. So I'm compiling gnome2 now, so I can run the
Code:
% compiz --replace --sm-disable --ignore-desktop-hints ccp &
% emerald --replace &
after I get into X.

Which leads me to

2) My mouse works in the console, but it's not working under the test screen when I run
Code:
X -config /root/xorg.conf.new
. I get the X window session with the mouse cursor, but it does not move. Will this be any different after I get gnome2 installed? Or if it is not working in the test screen it wont work with the window manager?

I used the handbook again for troubleshooting 'my mouse doesn't work in X' and linked mouse to sysmouse, did the vidcontrol -m on thing, none of that changed the test screen.

Maybe I should just do sysinstall and start off w/ X system and try again?
 

adamk

Daemon

Reaction score: 267
Messages: 1,622

First off, you should probably limit a post to one problem. In this case, the primary problem is that your mouse isn't working. Please attach your /var/log/Xorg.0.log file to a post here.

As for compiz-fusion... It does not require that you have KDE or gnome installed, but compiz provides no desktop menu and no panel.. So running it without gnome or KDE means that you will have no graphical way to launch other applications (except from a terminal) unless you install some other sort of panel.

Adam
 
OP
S

soylentgreen

Member

Reaction score: 1
Messages: 39

Thank you adamk.

I checked the log and saw the 'AllowEmptyInput' was defaulting to 'on'.

I added the line:
Option "AllowEmptyInput" "FALSE"
to the 'serverlayout' section and the mouse is working now.
 
Top