Solved compiz does not start

Hi guys!

I'm new to FreeBSD, but I come from a lot of years using Linux. I am running 11.0-RC3 (this is the first one to support my wireless card). I think this is the appropiate place to post this, as I do not know if this is a bug or a misconfiguration... :)

I'm trying to get compiz to work. I have used this to set up compiz:

The problem is that when I run the command compiz --replace --sm-disable --ignore-desktop-hints ccp & the window manager closes and I am left with no window manager. I checked, it is mentioned in section that "You are probably missing a setting in /etc/X11/xorg.conf. Review this file carefully and check especially the DefaultDepth and AddARGBGLXVisuals directives"

I have added those directives to the xorg.conf file...

Here is my Xorg.0.log:
and my xorg.conf:

when running the compiz command with --debug, this is what is shown:
compiz (core) - Debug: Could not stat() file
/home/esalgado/.compiz/plugins/ : No such file or directory
compiz (core) - Debug: Could not stat() file
/usr/local/lib/compiz/ : No such file or directory

Any help will be welcome :)
Thanks a lot!

It turns out I did not know that gnome-shell can't work together with compiz. When compiz was started, gnome shell disappeared.

It looked like compiz did not work, because as I saw here:
If no other plugins are enabled, you'll have to enable the following plugins (without these plugins enabled, Compiz won't work properly): Composite, Gnome Compatibility, OpenGL, Window Decoration, Move Window, Resize Window, Place Windows.

So I checked some plugins and voila... compiz worked as is... but without gnome-shell. I saw somewhere else gnome-shell does not work with compiz.

Gnome settings had "desktop animations" activated, but they did not work.

I saw that if GNOME 3 is started from gdm, gdm NEEDS to have permission to access the video card... so adding gdm user to wheel and video, gave me my wanted gnome-shell animations :)