clamav wont build on 10.2 inside jail

asg

New Member


Messages: 9

Hi,

I am trying to install clamav (ports/clamav) on FreeBSD 10.2-RELEASE-p3 inside a jail.
The make process always stops at the tests:

Code:
[...]
gmake[4]: Leaving directory '/usr/ports/security/clamav/work/clamav-0.98.7/unit_tests'
gmake  check-TESTS
gmake[4]: Entering directory '/usr/ports/security/clamav/work/clamav-0.98.7/unit_tests'
gmake[5]: Entering directory '/usr/ports/security/clamav/work/clamav-0.98.7/unit_tests'
PASS: check_clamav
PASS: check_freshclam.sh
PASS: check_sigtool.sh
SKIP: check_unit_vg.sh
PASS: check1_clamscan.sh

I can wait forever, nothing happens.

When I abort the process, I get the following information:

Code:
Makefile:1016: recipe for target 'check2_clamd.sh.log' failed
gmake[5]: *** [check2_clamd.sh.log] Error 130
Makefile:957: recipe for target 'check-TESTS' failed
gmake[4]: *** [check-TESTS] Interrupt
Makefile:1067: recipe for target 'check-am' failed
gmake[3]: *** [check-am] Interrupt
Makefile:625: recipe for target 'check-recursive' failed
gmake[2]: *** [check-recursive] Interrupt

What could be the problem?

Thanks in advance.


Cheers
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,042
Messages: 39,674

Did you enable TESTS?
Code:
TESTS=off: Run compile-time tests (req. python)
 
OP
asg

asg

New Member


Messages: 9

Damn.... sorry for the noise...now its working

But, the question is: why is the port not building if I choose "TESTS"?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,042
Messages: 39,674

Not sure why, but there's a reason the option is turned off by default.
 
Top