• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

CDE for FreeBSD will not launch.

aimeec1995

Active Member

Thanks: 10
Messages: 140

#1
Using freebsd 11.1 amd64

I have installed the cde port and follow all of its instructions.

in /etc/rc.conf:
Code:
rpcbind_enable="YES"
dtspc_enable="YES"
dtcms_enable="YES"

env LANG=C startx /usr/dt/bin/Xsession


x just crashes

I have looked in the xorg log and I see no errors of any kind. Just x terminating..
 

aragats

Aspiring Daemon

Thanks: 285
Messages: 768

#2
Run X first, then run CDE to see what's going on:
Code:
X &
env DISPLAY=:0 <cde start command>
 

ShelLuser

Daemon

Thanks: 802
Messages: 2,010

#6
This is amazing!

I tried building the official CDE port a few times but it always breaks on me with an ksh93 related build error, and I never bothered to look deeper into that. So today I grabbed the port which Datapanic suggested and well, it just works. The only thing I don't like is the somewhat distorted brownish 'drops wallpaper' (second virtual desktop), it's brown in the port while I clearly remember that it used to be a blue / cyan background with raindrops on it.

But that's a mere detail, one I can fix myself if I have to by firing up my old Blade server and trying to grab the backdrops from there. I even have an old sparcstation somewhere in my basement with Solaris 7 on it, that's bound to have a full CDE installation as well.

For now I'm really happy that I found this. As soon as I figure out how to configure dtlogin in order to add KDE4 as an option I'm going to make it the official login manager. That brings back memories!

Now my FreeBSD machine has truly succeeded my trusty, deeply respected and still fondly remembered Solaris environments.

Thanks for sharing guys!
 

Datapanic

Active Member

Thanks: 99
Messages: 180

#7
Just a follow up on things to config on Mikael's port:

add
Code:
inetd_enable="YES"
rpcbind_enable="YES"
to /etc/rc.conf

Edit /etc/inetd.conf to add the following (making sure you only enable other services as needed - the default is nothing enabled):

Code:
dtspc stream tcp4 nowait root /usr/local/dt/bin/dtspcd  /usr/local/dt/bin/dtspcd
cmsd/2-5 dgram rpc/udp4 wait root /usr/local/dt/bin/rpc.cmsd rpc.cmsd
Add dtspc 6112/tcp #subprocess control to /etc/services
 

ShelLuser

Daemon

Thanks: 802
Messages: 2,010

#8
However, you don't really need that to get CDE to work. Not the "external port" that is. All I did was enable rpcbind which was enough to get the whole thing to start. Apart from the obvious services of course such as dbus and hald.
 

ShelLuser

Daemon

Thanks: 802
Messages: 2,010

#10
Datapanic True that, but I also use KDE so I'm keeping those services around for now.

Speaking of which, I did it :) Took me a moment to (re)figure the whole dtlogin out but it works like a charm, with only one small caveat so far...

First locate /usr/local/dt/config/C/Xresources.d. Those session files are the ones responsible for the different session choices which you get in the dtlogin window. You can overrule any of those if you want to by using /usr/local/etc/dt/config. However, you'll notice that by default this directory only has an unrelated Xsession.d directory.

SO... # mkdir -p C/Xresources.d, this is the first command you'll need. Add a file in there, just to keep the sequence in order I used 0180.session. Then I added this:

Code:
Dtlogin*altDtName:      KDE4
Dtlogin*altDtStart:     /usr/local/bin/startkde
After you fire up your login manager with this you'll have a fifth option to chose from: KDE4 :cool:

The only caveat I spotted so far was when I logged out of KDE back into dtlogin. During that moment it no longer recognized KDE4 for some reason. I used the current option instead and (obviously) logged right back into CDE. After I logged off though the menu once again recognized KDE4.

So it looks like I'll be using a login manager again. This brings back some good memories to be honest. Especially seeing files such as Xaccess and Xservers; that's how I used to mess around with CDE back in the days. I had a Linux computer and a Solaris server, so I used X on the command line to log onto the login manager (dtlogin) and from there on use the CDE environment, but all from my own Linux workstation / server.

The only things left on my todo list as the blueish waterdrop wallpaper and the distorted console I get when using X together with the x11/nvidia-driver port. I assume the distortion is because of the differences in resolution between the (vt operated) console and the X environment, but I'll have to look closer into that, needs some more studying on my part.

Even so, this is very exciting. It's been years since I last logged onto a real CDE environment, and it really feels good to have it back!