CARP + IPv6 + Duplicate address

einsibjani

New Member


Messages: 7

I have CARP + haproxy setup on two servers, which was working fine with 11.2. After upgrading both servers to 11.3
I'm getting this error

nd6_na_input: duplicate IP6 address xxxx:xxxx:xxxx:xxxx::xxxx

and intermittent loss of connectivity. This only started after the upgrade. I've tried disabling IPv6 DAD,
net.inet6.ip6.dad_count: 0

but that doesn't help, I still get the messages and loss of connection.

Any ideas?

.einar
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,907
Messages: 31,209

Do you need carp(4) for IPv6? Or did you intended to use it for IPv4 only? I have only used it for IPv4 myself and haven't had any issues with IPv6 (default off, not needed).
 
OP
OP
E

einsibjani

New Member


Messages: 7

Well, after trying everything I could think of (disabling CARP, shutting down haproxy, flipping every ip6 switch in sysctl the problem just....vanished. Could some kind of cache have caused this? It's my guess, since that would explain why it just magically fixed itself...
 

Rudy

Member

Reaction score: 6
Messages: 49

Do you need carp(4) for IPv6? Or did you intended to use it for IPv4 only? I have only used it for IPv4 myself and haven't had any issues with IPv6 (default off, not needed).
What is the best way to setup IPv6 for address failover instead of CARP? If you could point me to a good freebsd IPv6 guide for setting up duplicate addresses with a primary and failover, that would be great.
 
Top