Solved Can't write to NTFS partition. File doesn't show up in Windows.

tedbell

Member

Reaction score: 23
Messages: 64

Hi,
I am having a strange problem with fuse and NTFS partitions. I cannot copy from FreeBSD to an NTFS partition. I can copy files from NTFS but when I try to copy to, the file doesn't show up in Windows but leaves errors on the drive that have to be fixed with chkdsk. I am using dsbmd and have all the necessary fuse packages installed. FUSE is enabled in loader.conf and rc.conf. I am also using a UEFI system. My machine is a Lenovo y510p. If there's any configs I need to show just ask. Thanks in advance.

EDIT: I got the file to show up in Windows but it involved copying the files in FreeBSD, rebooting FreeBSD to verify if the files are still there, then booting Windows. If I boot Windows right after copying the files are not there.

EDIT 2: OK I think this has something to do with dsbmd/c not unmounting drives properly. I have been getting errors of drives not being unmounted properly when I manually mount them instead of automounting with dsbmc. I tried ejecting through pcmanfm and then remounting the NTFS drive that I copied files to and the files are there. They also show up in Windows. So this has to do with dsbmc performing unclean dismounts. Anyone know how I can fix this? Is it better to use the devd automount?
 
OP
OP
tedbell

tedbell

Member

Reaction score: 23
Messages: 64

Earlier write on NTFS file system was possible. But due to modification in windows it is not possible now.
Ah, that makes sense. I thought it had something to do with Windows. For now, it works by unmounting the drive in FreeBSD after I'm done the file transfer.

EDIT: Looks like the issue is with hibernation and "fast startup" https://askubuntu.com/questions/1090107/how-to-disable-windows-10-ntfs-write-lock-due-to-faulty-fast-startup-option-fr

I tried disabling hibernation/fast startup but nothing changed. I think I will stick to my original method of unmounting.
 

faysal76

New Member

Reaction score: 2
Messages: 9

Hi,
if you are using NTFS partition under MS Windows 10 then things changed. Windows 10 does not shutdown properly by using shutdown button. It hibernates instead of proper shutdown. So, you have to enable proper shutdown in your Windows OS.

Following link may be useful:
 
Top