Can't upgrade from 10.1-RELEASE to 11.0-RELEASE

ericr

New Member


Messages: 6

I'm having problems upgrading from 10.1-RELEASE-p40 to 11.0-RELEASE:

Code:
root@test:~ #  freebsd-update -r 11.0-RELEASE upgrade
Looking up update.FreeBSD.org mirrors... 4 mirrors found.
Fetching metadata signature for 10.1-RELEASE from update4.freebsd.org... done.
Fetching metadata index... done.
Inspecting system... done.

The following components of FreeBSD seem to be installed:
kernel/generic src/src world/base world/doc world/games world/lib32

The following components of FreeBSD do not seem to be installed:

Does this look reasonable (y/n)? y

Fetching metadata signature for 11.0-RELEASE from update4.freebsd.org... done.
Fetching metadata index... done.

The update metadata is correctly signed, but
failed an integrity check.
Cowardly refusing to proceed any further.
I've tried doing the upgrade on several different servers, all running 10.1-RELEASE (I even tried one with a fresh install of 10.1-RELEASE with no patches. No joy.) I get the same behavior on all of them.

I'm running the GENERIC kernel on all the servers.

Anyone have any ideas?

Thanks!
 

marino

Daemon

Reaction score: 445
Messages: 1,091

yes. Update to latest 10.3 first, then update to freebsd 11. It's quick.
 
  • Thanks
Reactions: Oko

adams

Member

Reaction score: 3
Messages: 31

An easier solution, especially if you have lots of machines and wish to avoid two upgrades, is to just grab /usr/sbin/freebsd-update from a 10.3 machine. Worked fine here (tested once so far).
 
Top