can't set the wol_ucast flag (ifconfig)

Dre

Member


Messages: 45

I don't seem to be able to enable the wol_ucast flag for some reason.

Code:
# ifconfig em0 | head -2
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=19b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4>
# ifconfig em0 wol_magic
# ifconfig em0 | head -2
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=219b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MAGIC>
# ifconfig em0 wol_ucast
# ifconfig em0 | head -2
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=219b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MAGIC>
# ifconfig em0 wol
# ifconfig em0 | head -2
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=319b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST,WOL_MAGIC>
# ifconfig em0 -wol_magic
# ifconfig em0 | head -2
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=119b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST>
#

Not that I can actually get the system to start with a multicast message but I can at least enable the flag for em0.

Any thoughts?
 
OP
D

Dre

Member


Messages: 45

Got WOL working with a unicast frame containing the "magic" content.
Still can't enable the wol_ucast flag...
 

richardpl

Aspiring Daemon

Reaction score: 68
Messages: 841

Looking in source it appears that driver/device? doesn't support WOL_UCAST.

Better to ask on mailing list(s).
 
Top