Can't seem to get dns from my isp, I'm using pppoe

sdad

Member

Reaction score: 1
Messages: 35

This is a fresh install, trying to set up PPPoE.

From the manual, I did this in /etc/ppp/ppp.conf

Code:
default:
  set log +debug Phase tun command # you can add more detailed logging if you wish
  set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.255
  enable dns

Verizon:
  set device PPPoE:fxp0 
  set authname admin
  set authkey password
  set dial
#  set login
  add default 10.1.2.3
I did this in /etc/rc.conf

Code:
ppp_enable="YES"
ppp_mode="ddial"
ppp_nat="YES" 
ppp_profile="Verizon"
Doing an ifconfig, tun0 shows the isp's gateway and assigned local ip address

I can ping both addresses from my local console. Takes <1ms for the local, and about 50ms for the gateway.

If I ping http://www.yahoo.com, however I get no resolv. I do know that my isp sends out this info, as a smoothwall installation comes up just fine. I'm currently behind the smoothwall.

You'll notice that I added enable dns as instructed. I also disabled set login, and I added in +debug for the log file.

I am able to read the log file, but I am way to entry level to know what it says. I tried adding lines to rc.conf to turn off the router, I created a start_if.tun0 file, but didn't help. Don't see where that's needed anyway, as tun0 is already up and talking to the isp.
I have since removed those suggestions and back to what I have listed above.


So, how do I go about troubleshooting this issue?
 

wblock@

Beastie Himself
Developer

Reaction score: 3,645
Messages: 13,850

Does /etc/resolv.conf have the right DNS servers after PPP connects?
 
OP
OP
S

sdad

Member

Reaction score: 1
Messages: 35

No, it doesn't What is in there is the ip for my lan gateway that was in place during the install (that's the smoothwall.)

To test the PPP, I remove the modem connection to the smoothwall, and put it into fxp0 instead. I then restart the modem followed by a restart on fxp0's computer. Wouldn't the system put the isp's gateway into resov.conf on boot? Obviously not as currently set up.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,645
Messages: 13,850

You don't need to restart the computer, just restart ppp:
# service ppp restart

I wouldn't think resetting the modem is necessary, but don't know.

Anyway, PPP should set the DNS servers in /etc/resolv.conf. However, I've had a PPP dialup setup consistently set the wrong DNS servers. Eventually I gave up and entered the right ones, and set the schg flag on resolv.conf so it would not be overwritten. "disable dns" in ppp.conf should do the same thing.

After your PPP link is up, manually enter the DNS servers in resolv.conf and see if DNS works. If it does, then you know everything else is functional. You can then either "disable dns" in ppp.conf, or search for other answers to get PPP to do the right thing.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,645
Messages: 13,850

There's a ppp.conf.sample in /usr/share/examples/ppp/. The pppoe entry varies from yours in several ways.
 
OP
OP
S

sdad

Member

Reaction score: 1
Messages: 35

After restarting the modem and computer, a peek at the resolv.conf file does show the 2 dns servers supplied by my isp, so the enable dns line is working. Still no resolv, nor can I traceroute to the dns servers. Traceroute can't find a route to them. I am certainly lacking a something here.

I tried doing a service ppp restart with the modem connected and running. I got back, after seeing a number of files being loaded, a message that said add route failed 0.0.0.0/0 network unreachable. So if I am able to fix this error, maybe my dns will work ???

I see 2 lines that might cause this to happen

under default:

Code:
set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.255
and

under Verizon:

Code:
add default 10.1.2.3
No idea what to do. Btw, does the add default address really need to be there? I never entered a default gateway when setting up smoothwall, yet it has sufficient info to work.

I did look through /usr/share/examples/ppp/ppp.conf.sample
didn't see anything that meant too much to me.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,645
Messages: 13,850

sdad said:
After restarting the modem and computer, a peek at the resolv.conf file does show the 2 dns servers supplied by my isp, so the enable dns line is working.
That's good news in many ways. It shows you that it's mostly working, anyway.

Still no resolv, nor can I traceroute to the dns servers. Traceroute can't find a route to them. I am certainly lacking a something here.
Please show the output of, say, % ping google.com and % netstat -r

I tried doing a service ppp restart with the modem connected and running. I got back, after seeing a number of files being loaded, a message that said add route failed 0.0.0.0/0 network unreachable. So if I am able to fix this error, maybe my dns will work ???

I see 2 lines that might cause this to happen

under default:

Code:
set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.255
and

under Verizon:

Code:
add default 10.1.2.3
No idea what to do. Btw, does the add default address really need to be there? I never entered a default gateway when setting up smoothwall, yet it has sufficient info to work.
That was one of the things that was different in the example ppp.conf entry for pppoe, no "add default" at all.
 
OP
OP
S

sdad

Member

Reaction score: 1
Messages: 35

I removed the default gateway. This removed the error on the ppp restart cmd. Didn't give me dns, however.
Ping to yahoo gives a host not found message still.

Did notice during boot this 2 liner buried in the dialog:

Code:
fxp0 link status changed to UP
Warning:attempt to domain_add(netgraph) after domainfinalized()
That made me try to move the set ifaddr line to under the set device line. Still gives message, so must be something else causing the message to show up.

netstat -r gives this:

Code:
Destination         Gateway     Flags      Refs      Use   Netif

10:1.2.3            link#5       UHS        0         0     tun0
98.1.2.3            link#5       UHS        0         0     lo0
localhost           link#4       UH         0         0     lo0
I did discover that the defaults heading has to be in the ppp.conf file. I get barked at if its not included.
 
OP
OP
S

sdad

Member

Reaction score: 1
Messages: 35

More research indicated that the list reported back by netstat -r was incomplete. There should have been a default route listed first, and it wasn't there. I an using dynamic info from the isp, so I needed to add a 3rd file, /etc/ppp/ppp.linkup. I filled in the file with the info supplied and I am now resolving domain names. I have some extremely nagging questions about what I just did, as all I did was fill in the blanks, and this leaves me feeling powerless for the next occurrence.
 
Top