Can't run xorg on ryzen 3 , vega 3 laptop....

FWIW, I have a Motile M142 laptop (Ryzen 3500U). In rc.conf I have kld_list="ig4 iichid amdgpu amdsmb amdtemp linux64 linux".

In /boot/loader.conf I have efi_max_resolution="1080p"

In /etc/src.conf I have PORTS_MODULES+=graphics/gpu-firmware-kmod

After a bunch of trouble I ended up keeping a local copy of https://github.com/freebsd/drm-kmod in /usr/local/sys/modules/drm-kmod and manually keep it in sync the version in drm-devel-kmod by doing git pull; git checkout $GH_TAGNAME, where GH_TAGNAME comes from the drm-devel-kmod Makefile. I do this whenever I update the port locally. All this elaborate set up to make sure that whenever I rebuild the kernel, the amdgpu module automatically gets rebuilt and copied to /boot/kernel/amdgpu.ko when I do installkernel, so that it stays in sync with the kernel + it gives me the option of going back to an older working version in case of trouble.
The iichid module is needed for the touchpad. In /usr/local/etc/X11/xorg.conf.d/touchpad.conf I have
Section "InputClass" Identifier "touchpad" MatchIsTouchpad "on" Driver "libinput" Option "Tapping" "on" EndSection

This is about where I ran out of motivation as I actually don't directly use this laptop all that much as it my gateway machine (to avoid having a UPS for it)! I did make sound and video work on it as well. Its touchpad is terrible but for $300 I can't complain as I can also run VMs and jails on it.
 
… In /etc/src.conf I have PORTS_MODULES+=graphics/gpu-firmware-kmod

Here:

Code:
% grep -v \# /etc/src.conf | sort

KERNCONF=GENERIC-NODEBUG
PORTS_MODULES= emulators/virtualbox-ose-kmod graphics/drm-devel-kmod graphics/gpu-firmware-kmod
WITH_CCACHE_BUILD=yes
WITH_MALLOC_PRODUCTION=yes
%

– and I have a routine that includes this, immediately before any build of world and kernel:

git -C /usr/ports pull --ff-only && git -C /usr/src pull --ff-only
 
That's for things such as 3D acceleration on video cards. I'm fairly sure that acceleration of this type is not a requirement to (simply) start X.
 
BSD boots to a login prompt. When I log in as user, console loads. No privileges to start xfce
Then I login as root, xfce starts. Chromium doesn't work for root except with a --no-sandbox flag. As a result neither the user nor the root have privileges for both xfce and chromium, which needs xfce.

pw showgroup wheel:*:0:root,myusername video:*:44:myuserusername
 
That sounds like that your $USER is not in the video group.
Yes. Added user to the video and wheel groups, but it did not work. I might have skipped some steps while installing xfce. Read a howto article, pkg installed slim, edited /etc/rc.conf to enable mouse, slim, hald and dbus, edited xinitrc to add exec xfce4-session

and also

echo 'exec startxfce4' > /home/myusername/.xinitrc nano /usr/local/etc/slim.conf # in file slim.conf # current_theme fsbd

After init 6 I could login via xfce as user.

Thank you.
 
Last edited:
Please remove it from your configuration.
Please tell me what is it that I need to remove from my configuration? The line current_theme fsbd or the entire slim.conf file or something else? As of now it works fine, but if there is something that you noticed as wrong in the 5 year old howto article that I followed, I will do so immediately.

Thank you.
 
You edited /etc/rc.conf to include a HAL-related line. That one line can/should be removed.

Thank you. Removed that line, not rebooting immediately - waiting for my terminal to finish portmaster -a that is running for the past 5 hours (BSD installed in under 30 minutes but this ports tree fix is taking so long). The command to update the ports tree appears to be compiling every software in the Ports tree. Looks like the O/S in my computer is going to be one with a 100+ GB footprint. :)

(After reboot I checked. The total space used is less than 5GB)
 
Top