Can't login - gnome-2.28 on 8.0-RELEASE

Uniballer

Well-Known Member

Thanks: 61
Messages: 333

#1
I'm stuck. I installed 8.0-RELEASE and got it working with GNOME 2.26.mumble (whatever the package was on the install DVD image). Then I deleted all ports and reinstalled with portmaster, starting with Xorg 7.4.2, then gnome2, etc.

After rebuilding, editing rc.conf to include 'gnome_enable="YES"' and rebooting I get a gdm display, but can't figure out how to log in. When I type printable characters they go in an unlabeled text box, but do nothing. I can click on the system name/release text and get it to switch to the other. There is nowhere else to type or click except for the accessibility stuff in the lower right corner. Did I skip a step or something?

I reinstalled gnome 2.26 from the DVD again for now...

Any suggestions would be appreciated.
 
OP
OP
Uniballer

Uniballer

Well-Known Member

Thanks: 61
Messages: 333

#3
upgrade failed

Thanks for at least trying to steer me in the right direction.

I tried to follow the upgrade instructions and now it's really broken. After updating the ports tree the "portmaster -a" failed to complete. I just updated the ports tree again and I'll see what happens now...

Honestly, at least it built when I started from scratch.

Updates will be slow. The sacrificial machine is a 1.7GHz P4.
 
OP
OP
Uniballer

Uniballer

Well-Known Member

Thanks: 61
Messages: 333

#4
procfs made the difference

I must have been almost finished with rebuilding ports because I managed to continue and they are now done. After the upgrade I was right back where I was before: everything built, and gdm runs, but doesn't allow me to login.

I mounted procfs before starting gdm and it now provides a list of available login names. This is a little disturbing because 2.26.x didn't require procfs to be mounted before allowing logins by typing the user name.

Thanks for getting me back on track.
 

mickey

Well-Known Member

Thanks: 63
Messages: 376

#5
Uniballer said:
After the upgrade I was right back where I was before: everything built, and gdm runs, but doesn't allow me to login.
What exactly do you mean by saying it doesn't allow you to log in? At which point does it fail? Can you provide a screenshot?

You also might want to check, if you have anything set in /usr/local/etc/gdm/custom.conf, perhaps from an older gdm installation. The port will not touch this file on reinstallation if it has been modified from the original. In this case, there should be a file /usr/local/etc/gdm/custom.conf.default, to which you might compare it to.
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 2,718
Messages: 11,257

#6
@mickey

I believe Uniballer then went on to say that mounting procfs solved his problem (second alinea).
 

mickey

Well-Known Member

Thanks: 63
Messages: 376

#7
DutchDaemon said:
I believe Uniballer then went on to say that mounting procfs solved his problem (second alinea).
mh, wasn't that clear to me. Having a list of users provided doesn't mean you actually can log in :)
 

natto_lover

New Member


Messages: 3

#8
Same happened to me.

Hi.
I just done a fresh install of 8.0-RELEASE amd64 on an Athlon64 box.
The gnome that was part of 8.0 worked, but when I done an upgrade of
the ports, I got the same thing as what Uniballer described.

After having installed xorg and gnome2 from the DVD, what I done is,

Code:
portsnap fetch
portsnap extract
portupgrade --batch -a
portupgrade -f gnome-media gnome-settings-daemon gnome-control-center
The screen I got from gdm was weird -- exactly as Uniballer describes.
Since I'm not logged on, I don't have a screenshot.
It would take me a digicam to get one.

I get a gray login dialog, that includes the following.
(1) a picture of a computer
(2) a text line showing the FQDN of the host, which toggles to and from
"FreeBSD 8.0-RELEASE" when clicked.
(3) a horizontal line
(4) two buttons, one labeled "Restart", the other labeled "Shutdown"

I don't have any special configuration. /usr/local/etc/custom.conf is
left untouched. It has absolutely no customization inside.

I don't have procfs mounted, because I have not found any documentation saying so.

What should be done? Any help is appreciated.
 

natto_lover

New Member


Messages: 3

#10
Was it FreeBSD that changed, not gnome?

Thanks SirDice.

Ok, now it works. Pretty much like ubuntu.

I found in http://www.freebsd.org/gnome/docs/faq2.html :

You did not mount the procfs file system. Procfs is not mounted by default in recent releases of FreeBSD. Consider adding the following line to your /etc/fstab file:
proc /proc procfs rw 0 0
So it seems that it is FreeBSD that changed, rather than gnome newly demanding procfs.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,618
Messages: 28,164

#11
natto_lover said:
So it seems that it is FreeBSD that changed, rather than gnome newly demanding procfs.
Wrong assumption. Procfs was removed somewhere during FreeBSD 3.x if I remember correctly. Gnome however started requiring it since version 2.20 (or somewhere around that time).
 
OP
OP
Uniballer

Uniballer

Well-Known Member

Thanks: 61
Messages: 333

#12
SirDice said:
Wrong assumption. Procfs was removed somewhere during FreeBSD 3.x if I remember correctly. Gnome however started requiring it since version 2.20 (or somewhere around that time).
In fact, Gnome 2.26 will run and allow logins on FreeBSD 8.0 Release without procfs mounted. Not Gnome 2.28, though. So something in Gnome 2.28 (or the FreeBSD port) has changed.
 

natto_lover

New Member


Messages: 3

#13
Will this issue be documented?

Ok, so its gdm that started requiring procfs recently.

I got over this issue, but I think other people are very likely to stumble over the same thing.

I think it should be handled by the gnome port installer somehow. Maybe just print out a warning pointing the user to some documentation to mount procfs. Does anybody know if any such care is taken?
 

noons

New Member


Messages: 3

#14
Just found this thread searching in google about the exact same issue. Here is my issue though, I am now locked into a gnome which I cant login to. How do I get into terminal or start without an X session? I have tried ctrl-alt backspace and had no luck..
 

halok

New Member


Messages: 1

#17
Well this is my first post on this forum, and this thread describes the problem i am having exactly, i'm now rebuilding gnome and i'll mount procfs and hopefully i can log in..

Been using freebsd for server for a while now and it runs beautifully, this is my first attempt at using it on the desktop. been using linux on desktop for years. Got to say i'm enjoying freebsd much more, its very much like gentoo (or gentoo is very much like freebsd)

Cheers everyone.. :)
 

moman61

New Member


Messages: 10

#18
Gnome 2.28

After trying and not being able to login to gnome, the post by Uniballer came in handy and I was able to login to gnome :)

When I click on System-Administration and then on an icon, I get an Unsupported window that is displaying how do I want to have the system work like in freebsd 6 or 7 mode?

Is there a way around that?
 
Top