Can't boot FreeBSD-10.3-RELEASE-i386.qcow2

I downloaded the pre-installed FreeBSD-10.3-RELEASE-i386.qcow2 and tried to boot it in a freshly installed VirtualBox 5.0.16 on Windows Server 2008R2. But it doesn't even boot. The virtual machine just immediately shows "FATAL: Could not read from the boot medium! System halted."

In the VirtualBox log I see:

PIIX3 ATA: LUN#0: disk read error (rc=VERR_NEGATIVE_SEEK iSector=0x0 cSectors=0x1)
VMMDev: Guest Log: BIOS: int13_harddisk: function 02, error 02 !
VMMDev: Guest Log: BIOS: Boot from Hard Disk 0 failed
VMMDev: Guest Log: Could not read from the boot medium! System halted.

Did I miss something?
Or is there some problem with the disk image? Or with VirtualBox?

The pre-installed .vhd did boot.
But the .cqow2 image is supposed to be the one targeted for VirtualBox.
As far as I know VirtualBox does not support qcow2 images. They're for QEMU.
SirDice: I tried to use the FreeBSD qcow2 image just because the download README file states that it can be used for VirtualBox.

When trying to use it with VirtualBox, there were no indications that it was not supported, either. When choosing a virtual disk image in VirtualBox, it offers the qcow2 file type, among many others (although qcow2 is not the native format of VirtualBox, which is vdi). VirtualBox also does not give any error message when selecting the FreeBSD qcow2 image either, even though it does give error messages if I choose other random files types. So there was no indication of a problem until I actually tried to boot.

If the qcow2 disk image really can not be booted by VirtualBox, why does the README say it can?
Maybe the VirtualBox software didn't read the documentation. It does in fact accept qcow2 images, when I try it...

There is a recent VirtualBox forum post saying that VirtualBox actually supports qcow fully, and some kind of readonly support for qcow2. So it seems the VirtualBox documentation is not quite complete.

Anyway, if qcow2 is in fact not usable for VirtualBox, then maybe the FreeBSD image download README should be revised?