Cannot find the right dependencies

sk8harddiefast

Daemon

Reaction score: 198
Messages: 2,157

I make a try to write a Makefile for Openshot. This are the dependencies that I cannot find on ports:
Code:
python-glade2
python-pygoocanvas
libgoocanvas3
libgoocanvas-common
libsdl1.2debian-pulseaudio
Also:
Code:
python-mlt2, melt, libmlt, libmlt-data and libmlt++3
are part of mlt?
 

wblock@

Beastie Himself
Developer

Reaction score: 3,645
Messages: 13,850

sk8harddiefast said:
I make a try to write a Makefile for Openshot. This are the plugins that I cannot find on ports:
Code:
python-gtk2
python-glade2
python-pygoocanvas
libgoocanvas3
libgoocanvas-common
python-mlt2
frei0r-plugins
librsvg2-common
libsdl1.2debian-pulseaudio
There are some naming standards in ports: Python module ports start with "py-", Perl with "p5-", Ruby with "rb-", and so on. So:
% locate py-gtk2
shows the x11-toolkits/py-gtk2. Don't know about the others, but you can always plug the significant part of the name into locate(1) or whereis(1).
 
OP
OP
sk8harddiefast

sk8harddiefast

Daemon

Reaction score: 198
Messages: 2,157

I have not python-glade2 but I have
Code:
/devel/libglade2
and
Code:
/devel/glade2
Witch one is the right?
This are the dependencies they gave me
Code:
x264
ffmpeg
python
python-xdg
python-gtk2
python-glade2
python-pygoocanvas
libgoocanvas3
libgoocanvas-common
python-mlt2
melt
MLT (libmlt, libmlt-data et libmlt++3)
frei0r-plugins
sox
librsvg2-common
libsdl1.2debian-pulseaudio
This are that I set on makefile.

Code:
LIB_DEPENDS=            x264:${PORTSDIR}/multimedia/x264 \
			ffmpeg:${PORTSDIR}/multimedia/ffmpeg \
			python:${PORTSDIR}/lang/python \
			python-xdg:${PORTSDIR}/devel/py-xdg \
			goocanvas:${PORTSDIR}/graphics/goocanvas \
			python-pygoocanvas:${PORTSDIR}/graphics/py-goocanvas \
			librsvg2:${PORTSDIR}/graphics/librsvg2 \
			frei0r:${PORTSDIR}/graphics/frei0r \
			mlt:${PORTSDIR}/multimedia/mlt \
			python-gtk2:${PORTSDIR}/x11-toolkits/py-gtk2 \
			sox:${PORTSDIR}/audio/sox \
			pulseaudio:${PORTSDIR}/audio/pulseaudio \
Is anything wrong / missing?
 

richardpl

Aspiring Daemon

Reaction score: 68
Messages: 841

I think you will first need to create at least new port of py-glade2.
 
Top