Can you help me with the Intel i225-v network adapter?

I'm a FreeBSD newbie but have experience in linux (my system uses Gentoo Linux).
Right now trying out FreeBSD I can install it using the .img-File on a USB-Stick, but am not able to get network to work.
ASUS ProArt Creator WiFi with Ryzen cpu.
lspci tells:
Ethernet controller: Intel Corporation Ethernet Controller I225-V (rev 03)
Ethernet controller: Aquantia Corp. AQC113CS NBase-T/IEEE 802.3bz Ethernet Controller [AQtion] (rev 03)

Both of them work on linux without any problem.

On FreeBSD at least the igc (the Intel adapter) port shows up, but configuration fails, it finds no carrier regardless of using dhcp or giving it a static ip address using bsdconfig.

Any idea what to do to get it work?
What version of FreeBSD did you try?
it finds no carrier regardless of using dhcp or giving it a static ip address using bsdconfig.
"No carrier" means no juice, it apparently cannot detect a 'carrier' signal on the wire. In other words, there is no physical connection. So everything that runs "on top" of that physical connection isn't going to work either. Configuring the interface isn't going to magically make the 'carrier' appear. As you have two ethernet interfaces, are you sure you used to correct one?

This could be due to a change in the specific variant of the chipset you have and the driver doesn't detect this. I have a AUS PRIME mainboard also with a I225-V, it's running stable/14 now but it was working fine with stable/13 too. I'm sure 13.2-RELEASE works.
I tried 13.2, 14RC and 15 unstable with the same result.
It‘s definetely no hardweare problem nor wrongly connected.
At least, without changing anything, on Linux when bootet on the same machine both ethernet interfaces work without any issuea.
ASUS seems to often mangle with firmware and/or uses "special" chipset versions. I have an ASUS Pro B560M @work with an (allegedly) I219-V NIC which also doesn't work (no carrier), while the (allegedly) same I219-V chipset on the ASUS board at home (some 7th gen Core ROG thingie...) works, but only reliably with offloading disabled. The same ("default"?) chipset in my old clevo laptop, 2 supermicro and one asrock board works without issues...

I'm using an i350-T4 @work and x710 SFP+ at home, so i really don't care about the onboard NICs and haven't looked any further into getting them to work...
In the 14 release of today is the (again) prospect of a support of the igc driver. I‘ll try this release next and will report the result here.
There's at least three versions of the I225-V. The early ones (v1 and v2) were quite buggy.

It might be worth looking to see what version you have. I don't have any on FreeBSD systems, but lshw will identify the version on Linux:
description: Ethernet interface
product: Ethernet Controller I225-V
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:01:00.0
logical name: enp1s0
version: 03
My recollection is hazy, but I'm pretty sure I ran FreeBSD 13.2 with this v3 NIC successfully.
In my newly installed FreeBSD 14 my ethernet devices still don‘t work.
The lshw-command is not there and I cannot install anything without connection to the internet.
Any suggestions? Do I have to give up?
By setting the ip etc manually, the device „igc0“ is active. I can ping the conigured ip adress successfully (in my case, but not the router ip (
try to force media with ifconfig
ifconfig igc0 media 100basetx-fdx or ifconfig igc0 media 1000baset-fdx
and see what happens
I would have expected the igc(4) driver to work with an I225-V (rev 03) under FreeBSD 13.2 and 14.0.

So we are probably looking at something esoteric. Both covacat and bakul above have good advice.

However, I always have at least one spare USB Ethernet adapter to get the system self-supporting quickly when these sorts of things happen. Those with the AX88179 chipset cover the bases (but they need to be tweaked at boot time).
ifconfig shows the static ip that Yi configured before, but dadly „no carrier“ in status

igc0@pci0:12:0:0: class= […]
vendor = ‚Intel corporation‘
device = ‚Ethernet Controller I225-V‘
class = network
subclass = ethernet
ifconfig shows the static ip that Yi configured before, but dadly „no carrier“ in status
In general provide full information even if you think it is unnecessary as we may notice something that may be critical! Ideally you can cut and paste the actual output but if that is not possible take a photo (that shows the details) and post it.

Which *specific* ASUS model? Is it this board?
Note that in general FreeBSD support will lag behind Linux.
I‘m grateful that you guys take so much consideration in my problem!
As for my MoBo;
ASUS ProArt X670E-Creator WiFi
I‘ll send a Photo from the output and post it later.
The next thing for me to do is to try out a USB-network adapter, at least to connect the system to the internet. Let‘s see how it goes…
Halleluja, got internet with the usb network adapter. Had to recompile the kernel, but it works.

igc00pci0:12:0:0: class= 0x02000 rev=0x03 hdr=0x00 vendor=0x1d6a device=0x94c0 subvendor=0x1043 subdevice=0x87f5

sorry not having it posted in the first place.

Can you further assist me in bringing the igc-device up or at least understand why it will not work?
There is no freebsd support for this vendor/device. Looks like Linux is using a driver written by aQuantia which is GPL only.