"Burncd" and ioctl(CDRIOCFIXATE): Input/output error

Greetings FreeBSD Forum Folks;

I use "Burncd" to burn .iso images to a cdr disk. I get an error messages at the completion of the burning process.

The Error messages is as follows:
"burncd: ioctl(CDRIOCFIXATE): Input/output error"

When I invoke Burncd I use the followning commandline syntax: "burncd -v -f /dev/acd0 -s30 data Some.iso fixate eject"


FreeBSD 6.4 Release
acd0: CDRW <ATAPI CD-RW 52X24X/MB51> at ata1-master UDMA33
CPU: AMD Athlon(TM) (1200.05-MHz 686-class CPU)
<ASUS A7V600> motherboard

Before you jump on the post bandwagon here is what I have done to fix this problem.

I have switched motherboards from an "Asus a7a266" to an "Asus a7v600 they use different chipsets.
I have switched all of the "IDE Cables" out for new ones.
I have used "3" yes Three different cdrw burners
1. ATAPI CD-RW 52X24X/MB51 This is a generic drive that works when no others will
2. Plextor 708A
3. Benq DW1665(B)

I have even used different "HardDisks"

Please don't say something like "I use Cdrecord" When I place "atapicam_load="YES"
in the loader.conf, even more errors are spit out into "dmeg" and "/var/log/messages".

After the above error message the newly burned cdrom will mount and is readable.

I have another computer that has an "Asus MotherBoard" that has the "Intel" 440BX chipset
I can burn cdroms all day long with no errors. What this tells me is that I am doing it right
on at least one machine.

When I set up my motherboards, I use the default settings. I think this removes some of the

Thanks In Advance
Forgot to ask a closing queston!!

Is their some bootloader.conf or rc.conf settings I should try?
Is their a particular cdrw brand or model that seems to work better than others?
Maybe a bios setting?

Seems very strange that I am having this problem after replacing all of the hardware in the computer except ram and cpu!!

I have the same problem and I used to know the a reason why it does this but it so far in my FreeBSD past that I can't recall exactly the reason.

Anyway if you don't mind loading the atapicam you can use cdrecord to burn cds on the command line. That is what I use, I like it better.
Mostly Solved

Hey Folks;

After lots of Beer and ciphering; I figured out some of what is causing the original error message.

I was using "-smax or -s40" switch while burning. I reread the burncd man page and noticed that if no speed switch was used the speed will default to "4".

The below cmd line seems to do the trick:

burncd -ev -f /dev/acd0 -s10 data some.iso fixate

Now if the new code that Joel@ mentions can be patched or copied to my system that would be "Great".

I bet if that new piece of code was on my system; I most probably could get the "Atapicam" module loaded without all of the error messages in the logs. I can burn a cdrom with "Cdrecord" that works but with lots of error messages in the log files

--SOLVED---"Burncd" and ioctl(CDRIOCFIXATE): Input/output error

Sorry it took so long to get back to the thread folks.

Joel@ I did as you suggested; I patched ata-queue.c recompiled the kernel and what do you know! Burncd now works with no errors