Building mysql57-server from ports - fatal error: 'endian.h' file not found

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,556
Messages: 30,264

Why are people installing mysql57-server and not mysql80-server? Just curious.
Why are people install MySQL at all? Why not MariaDB? Or PostgreSQL? Probably for the same reason a lot of MySQL 5.5 installations still exist today.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,556
Messages: 30,264

It installed but when i try to start the server `/usr/local/etc/rc.d/mysql-server start` it says starting mysql but then I can't connect
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
that error means the server's not running and `ps auxw|grep mysql` doesn't show any running processes
Look in /var/db/mysql/$(hostname).err for clues why it's not working.
 

Vull

Well-Known Member

Reaction score: 119
Messages: 285

Why are people install MySQL at all? Why not MariaDB? Or PostgreSQL? Probably for the same reason a lot of MySQL 5.5 installations still exist today.
I was wondering if maybe something was wrong with version 8.0, since people seem to be avoiding it. Or if maybe people are using version 5.7 because some other software depends on that specific version.

I used to use MySQL because SMF forums software and Wordpress were dependent on it, and also because available ISP hosting services were providing it, but not providing any other databases. When I tested it against PostgreSQL it was immediately noticeable that MySQL was much much slower. And so, after Oracle bought Sun Microsystems, since I wasn't working on SMF or Wordpress anymore, I quit using MySQL completely. MariaDB sounds interesting but I haven't ever tried it because Postgres seems so solid, and it does everything I need.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,556
Messages: 30,264

I was wondering if maybe something was wrong with version 8.0, since people seem to be avoiding it. Or if maybe people are using version 5.7 because some other software depends on that specific version.
Probably the main reason why people have 5.7, at least on FreeBSD, is because it's the default.
 
Top