Broadcom WiFi

chunky_monkey

New Member


Messages: 8

I tried the steps above and was looking hopeful until:

Code:
lucious# kldload if_bwn
kldload: can't load if_bwn: Exec format error
Still the same error. Any ideas?
Code:
lucious# uname -a
FreeBSD lucious.waffle.com 8.0-RELEASE FreeBSD 8.0-RELEASE #0: Sat Nov 21 15:02:08 UTC 2009     root@mason.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  amd64
 

chunky_monkey

New Member


Messages: 8

ok I updated the src files and now I'm seeing this

Code:
[root@lucious /usr/src/sys/modules/bwn]# make 
Warning: Object directory not changed from original /usr/src/sys/modules/bwn
awk -f @/tools/makeobjops.awk @/kern/device_if.m -h
awk -f @/tools/makeobjops.awk @/kern/bus_if.m -h
awk -f @/tools/makeobjops.awk @/dev/pci/pci_if.m -h
cc -O2 -pipe -fno-strict-aliasing -Werror -D_KERNEL -DKLD_MODULE -nostdinc   -I. -I@ -I@/contrib/altq -finline-limit=8000 --param inline-
unit-growth=100 --param large-function-growth=1000 -fno-common -g -O0 -DKTR -DINVARIANTS -fno-omit-frame-pointer -mcmodel=kernel 
-mno-red-zone  -mfpmath=387 -mno-sse -mno-sse2 -mno-sse3 -mno-mmx -mno-3dnow  -msoft-float -fno-asynchronous-unwind-tables -ffreestanding 
-fstack-protector -std=iso9899:1999 -fstack-protector -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes  -Wmissing-prototypes 
-Wpointer-arith -Winline -Wcast-qual  -Wundef -Wno-pointer-sign -fformat-extensions -c /usr/src/sys/modules/bwn/../../dev/bwn/if_bwn.c
In file included from /usr/src/sys/modules/bwn/../../dev/bwn/if_bwn.c:71:
@/net80211/ieee80211_ratectl.h: In function 'ieee80211_ratectl_init':
@/net80211/ieee80211_ratectl.h:66: error: 'struct ieee80211vap' has no member named 'iv_rate'
@/net80211/ieee80211_ratectl.h: In function 'ieee80211_ratectl_deinit':
@/net80211/ieee80211_ratectl.h:72: error: 'struct ieee80211vap' has no member named 'iv_rate'
@/net80211/ieee80211_ratectl.h: In function 'ieee80211_ratectl_node_init':
@/net80211/ieee80211_ratectl.h:80: error: 'const struct ieee80211vap' has no member named 'iv_rate'
@/net80211/ieee80211_ratectl.h: In function 'ieee80211_ratectl_node_deinit':
@/net80211/ieee80211_ratectl.h:88: error: 'struct ieee80211_node' has no member named 'ni_rctls'
@/net80211/ieee80211_ratectl.h:90: error: 'const struct ieee80211vap' has no member named 'iv_rate'
@/net80211/ieee80211_ratectl.h: In function 'ieee80211_ratectl_rate':
@/net80211/ieee80211_ratectl.h:98: error: 'struct ieee80211_node' has no member named 'ni_rctls'
@/net80211/ieee80211_ratectl.h:100: error: 'const struct ieee80211vap' has no member named 'iv_rate'
cc1: warnings being treated as errors
@/net80211/ieee80211_ratectl.h:101: warning: control reaches end of non-void function
@/net80211/ieee80211_ratectl.h: In function 'ieee80211_ratectl_tx_complete':
@/net80211/ieee80211_ratectl.h:107: error: 'const struct ieee80211_node' has no member named 'ni_rctls'
@/net80211/ieee80211_ratectl.h:109: error: 'const struct ieee80211vap' has no member named 'iv_rate'
@/net80211/ieee80211_ratectl.h: In function 'ieee80211_ratectl_tx_update':
@/net80211/ieee80211_ratectl.h:116: error: 'const struct ieee80211vap' has no member named 'iv_rate'
@/net80211/ieee80211_ratectl.h:118: error: 'const struct ieee80211_node' has no member named 'ni_rctls'
@/net80211/ieee80211_ratectl.h:120: error: 'const struct ieee80211vap' has no member named 'iv_rate'
@/net80211/ieee80211_ratectl.h: In function 'ieee80211_ratectl_setinterval':
@/net80211/ieee80211_ratectl.h:126: error: 'const struct ieee80211vap' has no member named 'iv_rate'
@/net80211/ieee80211_ratectl.h:128: error: 'const struct ieee80211vap' has no member named 'iv_rate'
*** Error code 1

Stop in /usr/src/sys/modules/bwn.
do I need to update the net80211 src tree as well? recompile the kernel?

Thanks for all the help so far, wouldn't even be close without this forum.
 

everypot

Active Member

Thanks: 7
Messages: 202

kldload if_bwn.ko

chunky_monkey said:
I tried the steps above and was looking hopeful until:

Code:
lucious# kldload if_bwn
kldload: can't load if_bwn: Exec format error
Still the same error. Any ideas?
Code:
lucious# uname -a
FreeBSD lucious.waffle.com 8.0-RELEASE FreeBSD 8.0-RELEASE #0: Sat Nov 21 15:02:08 UTC 2009     root@mason.cse.buffalo.edu:/usr/obj/usr
/src/sys/GENERIC  amd64
 

datsun280zx

New Member


Messages: 1

Ive been hacking away at trying to get my BCM4315 working on Release 8 #0 for about 6 days. Ive been reading various forums, personal websites, reinstalled freebsd about 3 times, used about 5 different drivers. Im lost.
Im trying to install it on my dell laptop a vostro 1500. Screen shots n such are hard for me to paste here.
Basically I boot up, su in, run dmesg | grep BCM and I only see my lan connection, the Broadcom 4401.
ifconfig shows me the broadcom ethernet 10/100, two firewire ethernet adapters and the loop back adapter.
I can access the internet, specifically ftp, to get drivers via the 10/100 adapter.
pciconf -lv | grep BCM shows me my wireless adapter
Code:
device = 'Broadcom Wireless B/G (BCM4315/BCM22062000)'
The drivers Ive tried so far are:

b44win.inf
bcm4sbxp.sys
bcmwl5.inf
bcmwl5.sys
bcmwl6.inf
bcmwl6.sys


I have installed /usr/ports/net/bwi-firmware-kmod
Loaded ndis and if_ndis
I use ndisgen to create the sys.ko files
I use kldload to load the files into the kernel
kldstat says
Code:
kernel
bcmwl5.sys
ndis.ko
if_ndis.ko
bwi_v3.ko
if_bwi.ko
I've added entries into my /boot/loader.conf file after each attempt ie
Code:
bcmwl5_sys_load="YES"
if_bwi_load="YES"
right on down the line of drivers
I made a wpa_supplicant.conf file with me network stuff in it
Code:
ssid="NETGEAR"
proto=DHCP
key_mgmt=NONE
priority=2
scan_ssid=1
Not much has been done in the rc.conf file as I dont have anything to configure
There is probably more Ive done over past 6 days. My brain is turning into tapioca. Does anyone have any suggestions?

These are some of the resources Ive been reading up on:

http://forums.freebsd.org/archive/index.php/t-8375.html
http://forums.freebsd.org/showthread.php?t=2477
http://forums.freebsd.org/showthread.php?t=2477&page=4
http://www.freebsd.org/doc/en/books/handbook/config-network-setup.html
http://dannyman.toldme.com/2005/01/05/freebsd-howto-ndisulate-windows-drivers/
http://www.freebsd.org/doc/en/books/handbook/network-wireless.html
http://www.freebsd.org/cgi/man.cgi?...ion=4&manpath=FreeBSD+8.0-RELEASE&format=html
http://forums.freebsd.org/showthread.php?t=8375&highlight=bcm4315
 

johnhollon

New Member


Messages: 2

NEW-TO-FREEBSD&UNIX: About My Broadcom Wireless BCM4315

NEW TO FREEBSD:'BROADCOM BCM4315 DRIVER' ASK FOR HELP

First of all, as a Chinese and do not learn enough, my English is very poor.

And I must learn how to use FreeBsd for some reason. This is my first time to take a post here, if you have any bad feeling of my writing, please be patient.......

After installed, everything of the machine looks like perfect except Broadcom Wireless BCM4315. To install the BCM4315 dirver, in 4 days, I tried every way shown in the forum and other website through google, But I just got nothing to work.

With ngis - I've tried almost every version including official and third drivers from 2004 to 2010, with bcmwl5.inf and bcmwl564.sys, sometimes .ko did nothing, sometimes cause fatal error, and every bcmwl6.inf and bcmwl664 cause fatal error.

With bwi in the ports, it seems did nothing. pciconf always shows none...

With bwi of "http://paradox.lissyara.su/bwi.02c.tar.bz2", cause a fatal error, some infomation is "has 4 cores......"

With bwn(4), can not kldload if_bwn, after kldload ssb, the BCM4315 shows none1 to ssb0, but can not work anymore, and sometiems, after kldload ssb, cause a fatal error.

I'm sure I have kldload every thing for ngis in the ngis way, and kldload firmware for bwi in the bwi way, and firmware bwn in the bwn way.

after all above, I called HP's technology support phone, and the answer is THERE IS NO SIGNED OR CERTIFIED BROADCOM DRIVER FOR UNIX, so they can not give any support to me.

DOES ANYBODY CAN TELL ME HOW TO INSTALL THIS DRIVER?

Though I can get the net through my LAN card, but it is very bad idea, as my work evn is wireless.

My computer is HP 4416s 171. FREEBSD is 8.0 REALESE

My pciconf info are below.

pciconf
Code:
none3@pci0:6:0:0:	class=0x028000 card=0x1508103c chip=xx431514e4 rev=0x01 hdr=0x00
	vender='Broadcom Corporation'
	device='Broadcom Wireless b/g (BCM4315/BCM22062000)'
	class=network
	bar[10]=type Memory, range 64, base 0x92000000, size 16384, enabled
	cap 01[40]=powerspec 3 supports D0 D1 D2 D3 current D0
	cap 09[58]=vendor (length 120)
	cap 05[e8]=MSI supports 1 message, 64bit
	cap 10[d0]=PCI-Express 1 endpoint max data 128(128) link x1(x1)
 

kpedersen

Daemon

Thanks: 354
Messages: 1,184

johnhollon

New Member


Messages: 2

Has no way to fix it...

I can not install BCM4315 driver in my hp 4416s 171...

I think there is no way to fix the problem except using ndis. And after tried every windows driver, I just got faild...

Will anybody share the *_SYS.ko file, fit AMD64 Freebsd 8.0-release?

Thanks a lot!
 

unsobill

Member


Messages: 28

guys follow instuctions from my post 174 on page 7 - it should work with 4315 and i386
its basically simple bcmwl5_sys.ko driver that loads on the startup - i get lots of trash in my tty1 so i have to switch to tty2 to work but at least wireless works !!! keep pounding it - you will find solution - i spent whole week to get it working, i know how u feel


p.s

by the way 7.2 works without any issues with ndis and 4315 driver
 

selven

New Member


Messages: 3

any idea if development for this driver is still going on and if there's any repository where i could get some source and manage to have try at this?
 

foo_daemon

Member

Thanks: 4
Messages: 43

Using 9-current: the bwi0 driver loaded properly for my BCM4311 (dell 1390 wlan card), but was frequently causing kernel panics in the 'taskq' function when I did an AP scan or tried to join a specific ssid. NDIS-derived driver is stable and works: how long has AP scanning been working on NDIS? I am very pleased with this =)
 

bluetick

Active Member

Thanks: 5
Messages: 117

I have a Dell netbook 1012 with the BCM4315, I've got the card working, but after a few hours it will hang/crash. Unloading/reloading the kernel driver does not work. The computer must be turned off, not rebooted, to reset the card.
The ndis driver will work, but must be loaded after the system is running, loading at boot time will cause a panic. This is with 8.1-prerelease.
 

SaveTheRbtz

Member

Thanks: 9
Messages: 83

bluetick said:
I have a Dell netbook 1012 with the BCM4315, I've got the card working, but after a few hours it will hang/crash. Unloading/reloading the kernel driver does not work. The computer must be turned off, not rebooted, to reset the card.
The ndis driver will work, but must be loaded after the system is running, loading at boot time will cause a panic. This is with 8.1-prerelease.
You can try turning off DMA:

Code:
hw.bwn.usedma=0
in # loader.conf
 

lebanon

New Member


Messages: 4

bluetick said:
I have a Dell netbook 1012 with the BCM4315, I've got the card working, but after a few hours it will hang/crash. Unloading/reloading the kernel driver does not work. The computer must be turned off, not rebooted, to reset the card.
The ndis driver will work, but must be loaded after the system is running, loading at boot time will cause a panic. This is with 8.1-prerelease.
I have a HP ProBook 4510s.
Using ndis driver results panic on load system.
Sent a request to Mailing list "freebsd-stable" - Broadcom 4315 not working.
Help run WiFi BCM4315.
 

lebanon

New Member


Messages: 4

wblock said:
My 4312/4315 wants DMA disabled in /boot/loader.conf
Code:
hw.bwn.usedma=0
OK.

cat /boot/loader.conf
Code:
if_bwn_load="YES"
hw.bwn.usedma=0
reboot
kldload bwn_v4_lp_ucode.ko
ifconfig wlan0 create wlandev bwn0
ifconfig wlan0 up

cat /var/log/messages

Code:
Aug 30 18:25:10 kernel: bwn0: firmware version (rev 478 patch 104 date 0x8701 time 0x657)
Aug 30 18:25:10 kernel: wlan0: ieee80211_new_state_locked: pending INIT -> SCAN transition lost
Aug 30 18:25:16 kernel: bwn0: status of RF switch is changed to OFF
Aug 30 18:25:16 kernel: bwn0: please turns on the RF switch
Aug 30 18:25:17 kernel: bwn0: status of RF switch is changed to ON
Aug 30 18:25:18 kernel: bwn0: status of RF switch is changed to OFF
Aug 30 18:25:18 kernel: bwn0: please turns on the RF switch
Aug 30 18:25:19 kernel: bwn0: status of RF switch is changed to ON
Aug 30 18:25:28 kernel: bwn0: status of RF switch is changed to OFF
Aug 30 18:25:28 kernel: bwn0: please turns on the RF switch
Aug 30 18:25:30 kernel: bwn0: status of RF switch is changed to ON
Aug 30 18:25:31 kernel: bwn0: status of RF switch is changed to OFF
Aug 30 18:25:31 kernel: bwn0: please turns on the RF switch
Aug 30 18:25:33 kernel: bwn0: status of RF switch is changed to ON
 

wblock@

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 3,615
Messages: 13,850

That "wireless switch" message only shows on mine when I turn the wireless switch off. Maybe the switch is stuck?
 

lebanon

New Member


Messages: 4

I can click on the switch
be printed to the console, for example, "switch ON"
After this, it is automatically transferred to OFF, and so on

The lamp on the switch is always burning
 

Deuce

New Member


Messages: 1

Trying to get ndis working with my Dell 1505 (BCM4321) card in my D820 laptop using WEP on FreeBSD 8.1-RELEASE #0 GENERIC i386.

Code:
> pciconf -v
-snip-
ndis0@pci0:12:0:0:      class=0x028000 card=0x000a1028 chip=0x432814e4 rev=0x03 hdr=0x00
    vendor     = 'Broadcom Corporation'
    device     = 'Broadcom 432AGN 802.11a/b/g/draft-n Wi-Fi Solution (BCM4321KFBG)'
    class      = network
-snip-
I have no problems generating the module and loading it appears to "work":
Code:
ndis0: <Dell Wireless 1505 Draft 802.11n WLAN Mini-Card> mem 0xecffc000-0xecffffff,0xe0000000-0xe00fffff irq 17 at device 0.0 on pci12
ndis0: [ITHREAD]
ndis0: NDIS API version: 5.1
I configure my wlan device with: ifconfig wlan0 create wlandev ndis0 ssid XXXX wepmode on weptxkey 1 wepkey 0xXXXXXXXXXX which leaves ifconfig output having:\
Code:
ndis0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 2290
        ether 00:19:7e:5b:d8:06
        media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
        status: no carrier
wlan0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 00:19:7e:5b:d8:06
        media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
        status: no carrier
        ssid Hurd channel 1 (2412 MHz 11b)
        country US authmode OPEN privacy ON deftxkey 1 wepkey 1:40-bit
        txpower 0 bmiss 7 scanvalid 60 bintval 0
I bring it up and it becomes:
Code:
ndis0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
        ether 00:19:7e:5b:d8:06
        media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
        status: associated
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 00:19:7e:5b:d8:06
        media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
        status: no carrier
        ssid Hurd channel 1 (2412 MHz 11g)
        country US authmode OPEN privacy ON deftxkey 1 wepkey 1:40-bit
        txpower 0 bmiss 7 mcastrate 6 mgmtrate 6 scanvalid 60 protmode CTS
        bintval 0
With ndis0 associated but wlan0 with "no carrier". I thought that the radio may be off, but sysctl dev.ndis.0 shows:
Code:
dev.ndis.0.%desc: Dell Wireless 1505 Draft 802.11n WLAN Mini-Card
dev.ndis.0.%driver: ndis
dev.ndis.0.%location: slot=0 function=0 handle=\_SB_.PCI0.RP02.PXS2
dev.ndis.0.%pnpinfo: vendor=0x14e4 device=0x4328 subvendor=0x1028 subdevice=0x000a class=0x028000
dev.ndis.0.%parent: pci12
dev.ndis.0.RoamDelta: 1
dev.ndis.0.MPC: 1
dev.ndis.0.PowerSaveMode: 2
dev.ndis.0.PLCPHeader: 0
dev.ndis.0.frag: 2346
dev.ndis.0.rts: 2347
dev.ndis.0.NetworkAddress:
dev.ndis.0.antdiv: -1
dev.ndis.0.FrameBursting: 0
dev.ndis.0.Afterburner: 0
dev.ndis.0.ledbh0: -1
dev.ndis.0.ledbh1: -1
dev.ndis.0.ledbh2: -1
dev.ndis.0.ledbh3: -1
dev.ndis.0.leddc: 0xa0000
dev.ndis.0.Interference_Mode: -1
dev.ndis.0.ccx_rm: 1
dev.ndis.0.ccx_rm_limit: 300
dev.ndis.0.EFCEnable: 0
dev.ndis.0.Country: BE
dev.ndis.0.Chanspec: 11
dev.ndis.0.WME: -1
dev.ndis.0.LOM: 0
dev.ndis.0.IBSSAllowed: 1
dev.ndis.0.ssid_auto_promote: 0
dev.ndis.0.RadioState: 0
dev.ndis.0.WZCCoexist: 0
dev.ndis.0.Managed: 1
dev.ndis.0.vlan_mode: 0
dev.ndis.0.BTCoexist: 1
dev.ndis.0.abcap: 1
dev.ndis.0.AssocRoamPref: 1
dev.ndis.0.RoamTrigger: 0
dev.ndis.0.11HNetworks: 1
dev.ndis.0.IBSSMode: 0
dev.ndis.0.IBSSGProtection: 2
dev.ndis.0.LegacyMode: 2
dev.ndis.0.band: 0
dev.ndis.0.BandPref: 0
dev.ndis.0.RateA: 0
dev.ndis.0.Rate: 0
dev.ndis.0.ApCompatMode: 0
dev.ndis.0.BandwidthCap: 2
dev.ndis.0.1028000A: Dell Wireless 1505 Draft 802.11n WLAN Mini-Card
dev.ndis.0.Environment: 1
dev.ndis.0.NdisVersion: 0x00050001
dev.ndis.0.BusType: 5
dev.ndis.0.InterruptNumber: 17
dev.ndis.0.ForcePIO: UNSET
dev.ndis.0.AdapterDesc: UNSET
dev.ndis.0.DriverDesc: UNSET
dev.ndis.0.Brand: UNSET
dev.ndis.0.WPA: UNSET
dev.ndis.0.featureflag: UNSET
dev.ndis.0.LegacyProbe: UNSET
dev.ndis.0.ledblinkslow: UNSET
dev.ndis.0.ledblinkmed: UNSET
dev.ndis.0.ledblinkfast: UNSET
dev.ndis.0.WME_qosinfo: UNSET
dev.ndis.0.IBSSLink: UNSET
dev.ndis.0.PwrOut: UNSET
dev.ndis.0.BadFramePreempt: UNSET
dev.ndis.0.scan_channel_time: UNSET
dev.ndis.0.scan_unassoc_time: UNSET
dev.ndis.0.scan_home_time: UNSET
dev.ndis.0.scan_passive_time: UNSET
dev.ndis.0.scan_passes: UNSET
dev.ndis.0.EnableAutoConnect: UNSET
Which, since the inf file says a RadioState of zero is enabled suggests to me that the radio is on. I've also tried fiddling with the wireless which, but that just seems to attach/detach the bluetooth and there is no affect on the wireless.

At no point does the WiFi light illuminate.

Any suggestions?
 

lebanon

New Member


Messages: 4

Deuce,
Click on switch WiFi On/Off
# ifconfig wlan0 down
# ifconfig wlan0 up

If status: no carrier, then again:
click on switch WiFi On/Off
# ifconfig wlan0 down
# ifconfig wlan0 up
 

everypot

Active Member

Thanks: 7
Messages: 202

Broadcom open sources wireless drivers!!

It could have saved so much effort if they did it earlier.

http://thread.gmane.org/gmane.linux.kernel.wireless.general/55418

Broadcom would like to announce the initial release of a fully-open
Linux driver for it's latest generation of 11n chipsets. The driver,
while still a work in progress, is released as full source and uses the
native mac80211 stack. It supports multiple current chips (BCM4313,
BCM43224, BCM43225) as well as providing a framework for supporting
additional chips in the future, including mac80211-aware embedded chips.
The README and TODO files included with the sources provide more
details about the current feature set, known issues, and plans for
improving the driver.

The driver is currently available in staging-next git tree, available at:

git://git.kernel.org/pub/scm/linux/kern ... xt-2.6.git

in the drivers/staging/brcm80211 directory.

---
Henry Ptasinski
 

hermes

Member


Messages: 37

I’m not yet sure if this is good or bad news. I mean – what do we gain? A Linux driver, no free documentation. Broadcom will sit back and see no requirement for any further action. After all, we got a Linux driver!

I don’t think this will have any impact on Broadcom WLAN support in OSes other than Linux. Maybe the developers can extract *some* information out of the source code, but that’s about it.
 

wblock@

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 3,615
Messages: 13,850

I don’t think this will have any impact on Broadcom WLAN support in OSes other than Linux. Maybe the developers can extract *some* information out of the source code, but that’s about it.
Being able to see how a vendor's code makes their hardware work is extremely useful to developers, and developers are the ones who create and maintain FreeBSD drivers.
 
Top