Broadcom 4401 chipset defaults to 10baseT/UTP Connection

eschleicher

New Member


Messages: 3

Hello all,

I have a old P4PE motherboard that I'm using to run a file server. I'm actually using FreeNAS but that runs on top of FreeBSD 6.4. The problem that I'm having is that when FreeBSD first starts up it sees my network card as 100baseTX capable when running ifconfig from the command line. However once I start transfering a file from my desktop computer to the BSD computer the connection drops to 10baseT/UTP I have tried forcing the connection using the ifconfig command however as soon as I force it to 100baseTX I loose the connection all together, it wont ping google or my desktop computer.

I know the connection (nic and cable) are not the problem because I used to have Xubuntu installed on this same machine and it worked fine. I haven't touched anything other than opening the CD drive since then.

This is my first time with BSD so I'm hoping that I'm just doing something that is obviously wrong but I can't figure out what it is.

I also posted my problem on the FreeNAS forums but I haven't been able to figure it out yet and I figured you guys over here would be more experienced with the command line part of BSD.

here is a link to the other post just in case
https://apps.sourceforge.net/phpbb/freenas/viewtopic.php?f=9&t=978&p=4137#p4137

Thanks for any help you can give
 

tingo

Daemon

Reaction score: 394
Messages: 2,041

Well, BCM 4401 uses the bfe(4) driver (perhaps you knew that).
Are there any messages (related to the nic) in /var/log/messages?
Or on the console? (I have never used FreeNAS myself, are the console messages viewable somewhere at all?)
Are there any errors on the interface?
 
OP
OP
E

eschleicher

New Member


Messages: 3

Yeah I knew that was the driver it used and I checked the man page for it and made sure that the 100baseTX and full-duplex commands would work.
 
OP
OP
E

eschleicher

New Member


Messages: 3

I'll check the logs when I get home and see if there is anything in there, I'm at work at the moment.
 

SirWinstonoboogie

New Member


Messages: 14

(NIC) nfe0 good to Loopback, but? ... Guidance Requested

Hello All,

1st, let me say that I'm quite new to this OS (I have Cisco training though), but I've done some searching around on this, let me try to put across my networking issue:

This is a new install (7.1) - I checked the Hardware Notes for my Mobo, prior to starting.
Its a Nvidia 'MCP51' controller, and it is listed for the nfe driver -

FreeBSD apparently recognizes it, so I'll get to the symptom.

-Ping Loopback > good
-Ping static 192.168.10.100 > Good

But after a Boot, and all the scrolling stuff appears, I get this hex error:

'nfe0 tx V2 error 0X6004'

I'm lost now, don't know where to start... but:

looked at ifconfig (this after searching around - the bolded partial, below apparently indicates a problem)
a partial listing below:

nfe0: flags=884(UP BROADCAST MULITCAST...)3metric 0 mtu 1500

options=8
. MAC
. inet6 XXXXXXXXX ....
. inet 0.0.0.0 netmask (hex)ff000000 bcast 255 255 255 255
. autoselect 100base /half duplex
status Active
*also, a line here-
'network_interfaces="lo0_nfe0'

Finally, there's another Nividia driver listed in the hardware notes, for the NForce4, which jives with the Mobo -
Is this a possibility- to change the driver?(I wouldn't know where to start, except the handbook)

Thanks in advance, I'll hang up an listen.

Oh, 1 last thing - the NIC is Gigabit capable, but I saw someplace (netstat or ifconfig, IIRC) which indicates 100 mbs @ half duplex. My network is not Gig. capable, but I am expecting AutoNegotiation.
 
Top