booting from install dvd, xpt_config time out

Am new to FreeBSD but have some experience with Linux.

Downloaded 10.3 ISO and burned it to DVD. Booted off the DVD everything worked fine, and then the bootup process stopped for about a minute, the error message popped up

run init driver hooks, still waiting after 60s xpt_config

The boot process continued and I got to the part where it allows you to install or boot the live version. Booting the live version got me to a prompt where I could log in as root. I didn't do the install because of the error. I did some googling and found some tips like turning off firewire in BIOS. That had no effect. I downloaded 11 the current version and tried that, same error. I unplugged all USB devices except for the keyboard, same error. I assume this error will appear after an install?

Mostly I'm wondering if this is a common problem with a common solution that I didn't find on google.

GA-P55A UD4P mother board
You probably have a dodgy player. I would suggest using a memory stick to install.