Battery problems

Naos

New Member


Messages: 7

Hi,

I have an Asus N56VV with Ubuntu, Windows 7 and FreeBSD. I've checked the remaining time of my laptop during FreeBSD and it was 1:39. Maybe because of Bluetooth, internet stuff (even if I'm not connected to the internet), CPU, NVidia and Intel graphic cards. How may I extend the battery life?

Thank you :)
 
OP
N

Naos

New Member


Messages: 7

This is my /boot/loader.conf:

Code:
hint.p4tcc.0.disabled=1
hint.acpi_throttle.0.disabled=1
dev.cpu.0.freq_levels: 800/14000 //not sure of this
performance_cx_lowest="C2"
economy_cx_lowest="C2"
hw.pci.do_power_nodriver=3
 

deflected

Member

Reaction score: 2
Messages: 24

Hi Naos,

It is wrong to use:
Code:
dev.cpu.0.freq_levels: 800/14000 //not sure of this
performance_cx_lowest="C2"
economy_cx_lowest="C2"

in /boot/loader.conf

1. Remove
Code:
dev.cpu.0.freq_levels: 800/14000 //not sure of this

and put:
Code:
powerd_enable="YES"

in /etc/rc.conf. This will start a small service that will automatically choose and switch best frequency for you. Take a look at powerd() for more information.

2. Move
Code:
performance_cx_lowest="C2"
economy_cx_lowest="C2"

from /boot/loader.conf to /etc/rc.conf.
 
OP
N

Naos

New Member


Messages: 7

So this is my /boot/loader.conf
Code:
hint.p4tcc.0.disabled=1
hint.acpi_throttle.0.disabled=1
drm.i915.enable_rc6=7
hw.pci.do_power_nodriver=3

and this is my /etc/rc.conf
Code:
hostname="intel"
keymap="it.iso.kbd"
sshd_enable="YES"
moused_enable="YES"
powerd_enable="YES"
performance_cx_lowest="C2"
economy_cx_lowest="C2"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="NO"
# -- sysinstall generated deltas -- # Sun Nov 17 15:27:43 2013
ifconfig_usbus0="inet 192.168.0.1  netmask 255.255.255.0"
ipv6_activate_all_interfaces="YES"
defaultrouter="192.168.0.1"
hostname="intel"
# -- sysinstall generated deltas -- # Sun Nov 17 15:30:52 2013
ipv6_activate_all_interfaces="YES"
defaultrouter="192.168.0.1"
hostname="intel"
 

kpedersen

Daemon

Reaction score: 1,547
Messages: 2,419

I noticed that setting the following in /etc/sysctl.conf resets (to C1) when you plug in or unplug the power adapter.
Code:
dev.cpu0.cx_lowest=C2
dev.cpu1.cx_lowest=C3

Whereas the following in /etc/rc.conf persists but doesn't allow you to set the second cpu to C3 (which is safe as long as one cpu is C2 to avoid lag)

Code:
performance_cx_lowest="C2"
economy_cx_lowest="C2"
 
Top