• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved asusoled - could not find any ASUS LCM device!

Jason_25

Member

Thanks: 1
Messages: 57

#1
I have an Asus G50V with the second OLED display above the keyboard. The asusoled program is supposed to work with it like this: http://asusg50oled.sourceforge.net/

I found the instructions for the program here: http://www.filewatcher.com/d/FreeBSD/9.0-release/i386/asusoled-0.10_5.tbz.13617.html

The kldstat output from the instructions ( kldstat -m uhub/ugen) is:
Code:
No such file or directory
The output from the program is:
Code:
Could not find any ASUS LCM device!
The relevant output from usbconfig is:
Code:
ugen3.2: <LCM ASUS> at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON
The instructions indicate a specific driver is not necessary because of the generic ugen driver. Where do I troubleshoot from here?
 

Jason_25

Member

Thanks: 1
Messages: 57

#2
I am still trying to get this to work many years later. Will I literally have to die first before getting an official FreeBSD package working?

How might I access the source code so I that I can figure out what is going wrong? The source code is not in the ports tree, so I am still stuck with Could not find any ASUS LCM device even when the line directly above is a kernel message describing the Asus LCM device.

How might I expedite this process so that It can be working in this decade?
 

aragats

Aspiring Daemon

Thanks: 339
Messages: 854

#3
How might I access the source code so I that I can figure out what is going wrong? ... The source code is not in the ports tree...
It is in the ports tree, did you run portsnap(8)?
Then navigate to /usr/ports/sysutils/asusoled and run make (as root), it will retrieve the source code and apply patches, you'll get:
Code:
$ ll work/asusoled-0.10/
total 74
drwxr-xr-x  4 root  wheel    12B Feb 11 19:44 .
drwxr-xr-x  3 root  wheel     8B Feb 11 19:44 ..
-rw-r--r--  1 root  wheel   2.1K Sep 13  2008 asusoled_hw.h
-rw-r--r--  1 root  wheel    20K Sep 13  2008 asusoled.c
-rw-r--r--  1 root  wheel   2.2K Sep 13  2008 asusoled.h
-rw-r--r--  1 root  wheel    58B Sep 13  2008 AUTHORS
-rw-r--r--  1 root  wheel   124B Sep 13  2008 ChangeLog
-rw-r--r--  1 root  wheel    18K Sep 13  2008 COPYING
drwxr-xr-x  2 root  wheel     8B Feb 11 19:44 data
drwxr-xr-x  2 root  wheel     3B Feb 11 19:44 example
-rw-r--r--  1 root  wheel   1.7K Feb 11 19:44 Makefile
-rw-r--r--  1 root  wheel   1.5K Sep 13  2008 Makefile.orig
 

Jason_25

Member

Thanks: 1
Messages: 57

#4
Thanks for that.

After some searching I found out one of the IDs in the source code was wrong.

To get the correct ID (change for your device number):
Code:
usbconfig -u 3 -a 2 dump_device_desc
Then to setup the modifications (cd to asusoled port):
Code:
make fetch
Then:
Code:
make extract
Then I edited the file work/asusoled-0.10/asusoled.c and changed the idProduct line to 0x175b to match my screen.

Then I ran:
Code:
make
Then finally:
Code:
make deinstall reinstall
I also needed to move uhid.ko to home and reboot to get the driver to load as per the instructions.

Unfortunately after 10 years the screen is almost burnt out. It is very dim and only the very top works. Back when it worked it was glorious and very bright. I should be happy the laptop is still working after all this time. See this thread on the screen degradation also:
https://rog.asus.com/forum/showthread.php?98011-Asus-G50v-Oled-Screen

It was good to get this solved nonetheless.
 
Top