arm64 on Raspberry Pi 3 - USB issue

skywarp

New Member


Messages: 1

Hello,
Getting back into FreeBSD, installed 12.0-RELEASE on a Raspberry Pi 3. Works for a little while until my usb keyboard starts repeating the previous keystroke for no reason, randomly.

Tried the same keyboard on a Beaglebone Black with 12.0-RELEASE, no sign of issues. I like the Pi though so I'd like to use it if I can.

Tried a different USB keyboard (also wireless), and the same issue happens.

I was able to capture a bunch of lines like this with "usbdump -i usbus0 | grep ERROR":
"(timestamp)... usbus0.5 DONE-INTR-EP=00000081, SPD=FULL, NFR=1, SLEN=0, IVAL=2, ERR=IOERROR"

So obviously something is going on. Any USB experts that can offer some troubleshooting help?
Thanks,
 

trev

Aspiring Daemon

Reaction score: 141
Messages: 745

I've had a similar issue I had put down to using a KVM among 6 systems, but your input suggests it is more widespread and non-specific than that. Curiously, it does not occur in Xterms and I generally run X Window systems, including on the RPi, RPi2 and RPi3.
 
Top