apache24 - compat6x dependency

m5f4k8

New Member


Messages: 6

When I'm trying to upgrade apache24 via packages:

pkg upgrade apache24

I get compat6x as a new dependency:

Code:
New packages to be INSTALLED:
   compat6x-amd64: 6.4.604000.200810_3

Installed packages to be UPGRADED:
   apache24: 2.4.26 -> 2.4.27
   apr: 1.5.2.1.5.4_2 -> 1.6.2.1.6.0

Number of packages to be installed: 1
Number of packages to be upgraded: 2
So it looks like new dependency is introduced: compat6x.

Meanwhile, when trying to upgrade the port via port sources with portmaster:

portmaster apache24

There's no new dependency:

Code:
===>>> apache24-2.4.26 >> (1)

===>>> The following actions will be taken if you choose to proceed:
   Upgrade apache24-2.4.26 to apache24-2.4.27
   Upgrade apr-1.5.2.1.5.4_2 to apr-1.6.2.1.6.0
So, to be concise, what's going on?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,302
Messages: 32,149

It's not www/apache24 that's pulling it in. There's no reason why Apache would need binary compatibility with FreeBSD 6.x, which is what misc/compat6x provides.
 
OP
OP
M

m5f4k8

New Member


Messages: 6

I also think so, hence my question here. But pkg upgrade doesn't pull any other new ports, just this one, so it looks like direct dependency. How to investigate it further?
 
OP
OP
M

m5f4k8

New Member


Messages: 6

I've upgraded www/apache24 using pkg upgrade, installing also this forced dependency.

pkg info doesn't show any connections for compat6x, and I can delete it afterwards, alone:

Code:
~ # pkg info -r compat6x-amd64
compat6x-amd64-6.4.604000.200810_3:
~ # pkg info -d compat6x-amd64
compat6x-amd64-6.4.604000.200810_3:
~ #pkg delete compat6x-amd64
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 1 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
   compat6x-amd64-6.4.604000.200810_3

Number of packages to be removed: 1
So, why pkg upgrade for apache24 pulls it, when it clearly has no bindings?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,302
Messages: 32,149

It doesn't. If it did you wouldn't be able to remove it without also removing apache24. That alone means it's not a dependency of apache24. So it wasn't Apache that pulled it in.

And you typically run pkg upgrade to update everything. Not just a single port/package.
 
OP
OP
M

m5f4k8

New Member


Messages: 6

The same thing now happens with lang/php56:

Code:
~ # pkg upgrade php56
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 2 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
   compat6x-amd64: 6.4.604000.200810_3

Installed packages to be UPGRADED:
   php56: 5.6.30 -> 5.6.31

Number of packages to be installed: 1
Number of packages to be upgraded: 1
Some kind of compat6x infection...
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,302
Messages: 32,149

It's not, that simply means it's something on your system that's causing it. There are simply no ports that depend on misc/compat6x. It would be rather pointless too as compat6x is used to provide the libraries required to run a FreeBSD 6.x binary on 7 or higher. Packages are built for specific FreeBSD versions so a package built for FreeBSD 10.x or 11.x doesn't require FreeBSD 6.x libraries.
 
OP
OP
M

m5f4k8

New Member


Messages: 6

It's not, that simply means it's something on your system that's causing it
Yes, something on my system. I can see that there are no ports that depend on compat6x, I can delete it after it's installed, without deleting anything else. So why pkg upgrade installs it at all? Clearly something is wrong. How can I investigate it further, prior to running pkg upgrade under debugger?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,302
Messages: 32,149

I would recommend running a full pkg upgrade and update everything. Things like this are usually caused by partial updates.
 

steinex

New Member

Reaction score: 7
Messages: 14

You can check with pkg query %ro compat6x which package depends on it.
 

ShelLuser

Son of Beastie

Reaction score: 1,769
Messages: 3,577

What binary repository are you using? Check /etc/pkg/FreeBSD.conf?
 
OP
OP
M

m5f4k8

New Member


Messages: 6

I would recommend running a full pkg upgrade and update everything. Things like this are usually caused by partial updates.
Maybe yes, maybe no. I, as the programmer, would be much more willing to investigate the problem when it appears, at hand, and well isolated, instead of trying to make it go away, somehow.


You can check with pkg query %ro compat6x which package depends on it.
None, empty list.

What binary repository are you using? Check /etc/pkg/FreeBSD.conf?
Code:
FreeBSD: {
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/quarterly",
  mirror_type: "srv",
  signature_type: "fingerprints",
  fingerprints: "/usr/share/keys/pkg",
  enabled: yes
}
Exactly the same problem! So the bug within my system is not that alone.
 
Top