Apache24 and mod_suexec

heximal

Member

Reaction score: 1
Messages: 48

Hi.
I've installed apache26 package via pkg install and now I can't get it work, apachectl configtest gives an error:

Code:
AH00526: Syntax error on line 8:
Invalid command 'SuexecUserGroup', perhaps misspelled or defined by a module not included in the server configuration
After that I could not find mod_suexec neither in httpd.conf, nor in libexec/apache24/ directory.
Are Apache24 and mod_suexec compatible at all?
 
Last edited by a moderator:
OP
OP
heximal

heximal

Member

Reaction score: 1
Messages: 48

I've decided to build apache24 via ports. I've found SUEXEC option in make config. But when I run make install, the installation fails with error:
Code:
Installing libressl-2.4.5...
pkg-static: libressl-2.4.5 conflicts with openssl-1.0.2k_1,1 (installs files into the same place).  Problematic file: /usr/local/bin/openssl
*** Error code 70
Do I understand right that apache24 is trying to use libressl instead of openssl? Can we make it continue to use openssl?
 
Last edited by a moderator:
Top