Any Renoise Interest?

Hi
I have been trying to see if i can get linux renoise running on fbsd for a while to no avail on 7.x, but recently installed 8-0 snapshot 200905 and just got a bit further, but wondering if anyone else interested or have some more insight.

The story so far :
The package comes with an installer script which i just edited the install destinations in it to try /usr/local/bin or under compat/linux (but seems it gives same results if run from the untarred folder in my home), and i installed audio/linux-alsa-lib.

On 7.x the app would fail complaining that i don't have an SSE2 cpu, even though i do, and had emailed the renoise support team asking for info on how renoise checks for this to shed some light, but they just replied that renoise is not supported on fbsd. I assumed it needed to look for cpuinfo in linproc but was looking in /proc instead, but i just let it be.

on 8.0-current (and linux_base-fc4) it got past that SSE problem but failed with a "relaytool stub call yada yada regarding linfontconfig.x...."; but since starting this post i updated base-fc4 to base-f10 and it loaded fine, only complaining that alsa driver not available, so sound will be disabled.

under preferences there is an option to select either alsa or jack as sound output, but when selecting jack ( and jack running beforehand with qjackctl) it complains that libjack.so.xxxx is not available.

That's it for me for today, but wondering if this will need fbsd jack libs in the right place for renoise to find, or linux jack libs installed.

if anyone has it running already or gets somewhere, please can you fill me in.(cross-posted freebsd-multimedia && @freebsd.forums.org )

thanks and regards.

p.s. I used both renoise demo 2.0 and renoise demo 2.1 rc1 (latest on their site)
 
You may want to try installing linux_base-f8 (Fedora 8 compat) and set compat.linux.osrelease=2.6.16 in /etc/sysctl.conf. That will get a more current version of linux compat.
 
i have that already in sysctl, and on your advice i deinstalled all linux ports and base-f10 and installed everything with base-f8. i left f10 earlier because it saw i still installed f8 stuff. anyway renoise is running better now, loads faster and exits properly, but still same problem with sound as above.

i will have to dig deeper later on, unless someone finds a solution or has it running already.

thanks for now man
 
I bought renoise some time ago, and now that i moved to FreeBSD i would like to use it here because it's a really valid program...
I installed it (renoise-2.5.0) in my /usr/local, by modifying the installation script as needed. It does start up well but i can't figure out how to solve the "no sound" issue.

For now i tried cpio'ing a jack-audio-connection-kit from fc10 inside my /compat/linux, unsuccessfully.
I haven't found an easy way to emulate an alsa device for renoise and i think (hope) it would be easier to make it work by using jack... Maybe by using jackd from compat/linux? Haven't tried.

It's a mess that Renoise hasn't got OSS support, as it would make it easier to run it (or actually USE it) on FreeBSD (and maybe other *nixes), maybe they read the all-caps DEPRECATED word in the linux kernel config...). Does someone know what is the hardness in making an application OSS-aware?

Cheers
 
Top