alarm clock

So then you should do this:
  • put a copy at /usr/ports/deskutils/alarm-clock-applet
  • install ports-mgmt/synth
  • execute synth test deskutils/alarm-clock-applet
  • if it builds successfully, attach the build log to the PR (this will ping it)
  • if it falls to build, fix the problems and attach the final build log to the PR (along with the updated submission)
I can build and install it with portmaster

but synth says
the portmaster output is useless based on how it works. You might as well build it from the command line with make install. There's a reason nobody asks for portmaster logs.

Edit /usr/ports/deskutils/Makefile and add alarm-clock-applet to it.
Sorry about this extra step, but it comes from FreeBSD ports considering only ports in category Makefiles as valid.
You need to install ALL these ports/pkgs!
LIB_DEPENDS=${PORTSDIR}/[b]x11-toolkits/gtk20[/b] \${PORTSDIR}/[b]x11-toolkits/pango[/b] \${PORTSDIR}/[b]devel/libnotify[/b] \${PORTSDIR}/[b]devel/glib20[/b] \${PORTSDIR}/[b]devel/glib20[/b] \${PORTSDIR}/[b]x11-toolkits/pango[/b] \${PORTSDIR}/[b]print/freetype2[/b] \${PORTSDIR}/[b]devel/gconf2[/b] \${PORTSDIR}/[b]graphics/cairo[/b] \${PORTSDIR}/[b]textproc/libxml2[/b] \${PORTSDIR}/[b]x11-toolkits/unique[/b] \${PORTSDIR}/[b]x11-toolkits/gtk20[/b] \${PORTSDIR}/[b]devel/gettext-runtime[/b] \${PORTSDIR}/[b]accessibility/atk[/b] \${PORTSDIR}/[b]multimedia/gstreamer1[/b] \${PORTSDIR}/[b]devel/glib20[/b] \${PORTSDIR}/[b]x11-fonts/fontconfig[/b] \${PORTSDIR}/[b]graphics/gdk-pixbuf2[/b] \${PORTSDIR}/[b]devel/glib20[/b] \${PORTSDIR}/[b]x11-toolkits/pango[/b]


For example
% sudo pkg ins x11-toolkits/pango devel/glib20 graphics/gdk-pixbuf2 x11-fonts/fontconfig … … etc, etc, etc
He should synth test his version first to illustrate a point. :)
I'm using tobik's updated version with "the appropriate USE_* flags" now.

So it seems that synth is woking fine now, synth test deskutils/alarm-clock-applet is running now —

It seems that I need to wait while some ports will be built?
When it will be finished I'll post output here.
we'll, you should expect it to pass because tobik already validated it with poudriere.

It would have been more valuable to check *your* version to illustrate the problems even after you were convinced the port was good. I mean as a learning experienced. Build-testing a port that already passes won't prove much unless there's a rare issue that synth can detect and poudriere can't (there aren't many of those).
ILUXA@ by the way, your Synth seems pretty old (The labels "skipped" and "swap" aren't capitalized which indicates an older version). Are you using a quarterly branch?
It was installed from pkg's ~30 minutes ago :). I'm using ports only when I need to change some build options (Or, sometimes, when I need to install a newer version, what will be done when synth will finish).
well, then your packages are set for the quarterly branch. Verify with pkg -vv. If that is what you want, fine.

(just because it was installed 30 minutes ago doesn't mean it's not 2 months old)
I've never realized that I'm using it.
It seems that "quarterly branch" is set by default in FreeBSD 11 by now.
(I'm googling some info now and it seems that "quarterly branch" is set by default starting with 10.2)
How can I easily switch to 'latest'? I did not find such option in /usr/local/etc/pkg.conf.

I found how to change it:

1. mkdir -p /usr/local/etc/pkg/repos
2. cp /etc/pkg/FreeBSD.conf /usr/local/etc/pkg/repos/FreeBSD.conf

and in the /usr/local/etc/pkg/repos/FreeBSD.conf :

- url: "pkg+${ABI}/quarterly"
+ url: "pkg+${ABI}/latest"
That's for those, who are like I am :D I always thought that it's OK that pkg's from repository are outdated a little.
Huge thanks, marino@ ! If you did not mention about "quarterly branch" I would never realize that I'm using it, I've read A LOT OF forums and mailing lists, but I've never heard about it.
  • execute synth test deskutils/alarm-clock-applet
  • if it builds successfully, attach the build log to the PR (this will ping it)
Here is output… ( s is sudo and c is cat)

I don't get it. What I need to do next?
look at the build log.
editors/joe => editors___joe.log
deskutils/alarm-clock-applet => deskutils___alarm-clock-applet.log

the man page describes this too.
in this case, you need to look at log starting with 00_
if you list the directory alphabetically, it's at the top.
finally, you can always use a brower to show "/var/log/synth/Report/index.html" which shows a lot. (newest synth versions only)
You should report the flaw.
Synth detected a missing entry in the plist because you built with "synth test" which invokes QA tests.
After you file a PR (and you should), use synth just-build textproc/py-sphinx which skips the tests, then try testing the alarm clock again.
Congratulations ILUXA!

Maybe you want to share some of your experience with us, how you finally made it, and what the reason was that it took so a long time?

I don't know why it took so long, because no answer was given until now.

Also many thanks to tobik@ for the help!

For newcomers:

Now alarm-clock-applet is available in ports tree !
Alarm Clock is a fully-featured alarm clock for your GNOME panel or
equivalent. It's easy to use yet powerful with support for multiple
repeatable alarms, as well as snoozing and a flexible notification
system. Alarm Clock will notify you of an alarm by either playing a
sound or starting your favorite music player!
I use the alarm-clock applet. It compiles and runs just fine for FreeBSD.
It does not compile for me under FreeBSD 13.2 OR GhostBSD 23.07.29 get:

CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
Call Stack (most recent call first):
/usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:600 (_FPHSA_FAILURE_MESSAGE)
/usr/local/share/cmake/Modules/FindPkgConfig.cmake:99 (find_package_handle_standard_args)
CMakeLists.txt:48 (find_package)