Akonadi suddenly started moving thousands of files

rawthey

Member

Reaction score: 20
Messages: 87

While idly sitting watching Youtube a pop-up appeared on my screen announcing that thousands of files were being moved to activities/current. After pausing the file transfer I was able to obtain this screenshot.

plasma.png


This is the first time in several years of using KDE that I've ever seen anything like this. Should i worry?

Judging from the output of top it looks like akonadi is the culprit
.
Code:
last pid: 18486;  load averages:  0.47,  0.56,  0.41                                                                  up 0+10:49:01  19:18:43
165 processes: 1 running, 162 sleeping, 2 zombie
CPU 0:  2.7% user,  0.0% nice,  8.2% system,  0.4% interrupt, 88.6% idle
CPU 1:  3.9% user,  0.8% nice,  5.5% system,  0.0% interrupt, 89.8% idle
CPU 2:  9.8% user,  0.0% nice,  3.1% system,  0.4% interrupt, 86.7% idle
CPU 3:  2.4% user,  0.4% nice,  6.7% system,  0.0% interrupt, 90.6% idle
Mem: 1393M Active, 2998M Inact, 292M Laundry, 10G Wired, 48K Buf, 747M Free
ARC: 7143M Total, 2808M MFU, 3600M MRU, 406M Anon, 72M Header, 487M Other
     6016M Compressed, 7641M Uncompressed, 1.27:1 Ratio
Swap: 8192M Total, 8192M Free

  PID USERNAME    THR PRI NICE   SIZE    RES SWAP STATE    C   TIME    WCPU COMMAND
14450 mike         41  20    0   445M   323M    0 select   0   1:16   7.28% mysqld
14496 mike          4  40   19   141M    78M    0 zcw->z   0   0:14   4.82% akonadi_indexing_ag
14528 mike         25  21    0   769M   418M    0 select   2   1:14   4.00% kmail
14366 mike         14  20    0   498M   226M    0 zcw->z   0   0:38   1.99% plasmashell
14442 mike         45  20    0   176M    82M    0 select   2   0:17   1.46% akonadiserver
14493 mike          7  20    0   370M   190M    0 select   3   0:13   1.31% akonadi_imap_resour
17874 mike          1  20    0    19M    10M    0 kqread   0   0:06   1.19% imap
17510 mike         24  20    0  2781M   535M    0 select   1   3:33   0.68% firefox
14317 mike          1  20    0    14M  5196K    0 select   1   0:08   0.64% dbus-daemon
14283 root          2  20    0   104M    78M    0 select   1   3:13   0.47% Xorg
 
OP
R

rawthey

Member

Reaction score: 20
Messages: 87

Now I'm even more confused. When the copying finished it gave me the option to open the containing 'folder'. Despite having claimed to have moved 8,980 files there was nothing there.

activities.png
 
Top