After update to NTP 4.2.8p8-a NTP crashes with no error messages in log

After the FreeBSD security notice about NTP, I did the system update (I run AMD64 FreeBSD 10.3) and then updated my NTP port. I run NTP via ports. The port built with no problems. The messages log showed no errors. I attempted to restart NTP. I did a status and it wasn't running. The message log is clean. Here are the lines:

Jun  4 10:15:43 lily ntpd[40079]: ntpd 4.2.8p8-a (1): Starting
Jun  4 10:15:43 lily ntpd[40080]: leapsecond file ('/var/db/ntpd.leap-seconds.list'): good hash signature
Jun  4 10:15:43 lily ntpd[40080]: leapsecond file ('/var/db/ntpd.leap-seconds.list'): loaded, expire=2016-06-01T00:00:00Z last=2015-07-01T00:00:00Z ofs=36
Jun  4 10:15:43 lily ntpd[40080]: leapsecond file ('/var/db/ntpd.leap-seconds.list'): expired less than 4 days ago

There is a PID but the process is not running. I recompiled with debug set on, but still this is all I get. Everything was fine prior to the system and port upgrade. I have been running on the latest version of everything.

Please help.
I'm using ntp from base and it works fine after using a different leap-second file sources.

Firstly, I added this line in /etc/rc.conf

Then I ran service ntpd fetch to update /var/db/ntpd.leap-seconds.list

See PR 209577 for further details.
I tried this and no luck. NTP just dies when I try to start it. I also deleted all the /var/log/db/ntp/* files. It refetched the leap second file and then died.
Some questions to consider:

Have you modified ntp.conf(5)? Have you updated properly FreeBSD? Have you rebooted the machine after the update?

In other case, please, file a new PR providing useful information related to this issue.
I updated FreeBSD the same day I updated the port. I am fully up to date with everything. I made no changes to ntp.conf or any other config file. All I did was the most recent FreeBSD update (I am running 10.3 on amd64). After completing the update, I then ran portmaster(8) and updated several ports, one of which was NTP. I rebooted after the system update and before the port updates. My messages log is totally unhelpful. All seems normal, but the process seems to start and die as soon as it starts.

I put my log results in my initial post. I am trying to register on Bugzilla so I can create a PR. So far the confirmation email has not arrived.