LXDE About lxde

Emrion

Active Member

Reaction score: 40
Messages: 194

Hello,

I installed lxde with the help of sysutils/desktop-installer. I use x11/xdm for login. The ~/.xsession file contains:
ck-launch-session dbus-launch --exit-with-session startlxde
Globally, it's working and I'm pleased with this interface. But there are some things that are not working properly.

First, it's easy to change the screen resolution with preference / monitor settings but it does not survive to a logout. Of course, I saved the settings with the "save" button. But when I login, it first set to the resolution I saved and quickly returns to 800x600.
I overcame this by setting a resolution conf file in /usr/local/etc/X11/xorg.conf.d. Nevertheless, it isn't normal. Bug or is there something I didn't understand?

Another annoying thing is the creation of an application shortcut on the desktop. Again, very easy to do (just drag and drop an item from the main menu) but when I double-click on the shortcut, a message windows asks "The text file ... seems to be an executable script. What do you want to do with it?". Then, you have to click on "execute" button to launch the said application. I found no way to get rid of this warning (no permission problem, no results in modifing the shortcut file which is actually a text file).

And it's just my first day with lxde. So beautiful, so annoying... Is there somewhere a documentation I shall read before I delete this and shift to another desktop environment?
 

Sevendogsbsd

Aspiring Daemon

Reaction score: 249
Messages: 527

I think you understood the issue with xorg correctly. I am guessing, because I don't know how LXDE setting for display are implemented, but as you have figured out, they aren't persistent. Not sure if LDXE provides some sort of settings restore at autostart?

Putting the config under /usr/local/etc/X11/xorg.conf.d is the correct solution globally as far as I am concerned. Personally, I have never let a DE adjust my resolution settings and have only done it using separate configs (when necessary) under /usr/local/etc/X11/xorg.conf.d as you have done.

I don't have any insight into your other issue as I've never used LDXE.
 

b6s6d6

Member

Reaction score: 15
Messages: 36

Maybe you should try LXQt, which is the continuation of the old LXDE .
It's already available in FreeBSD (at least in the 'latest' repo, not sure about 'quarterly') with a simple:
sudo pkg install lxqt sddm
(sddm is optional, just if you want to use it instead of xdm)
 

shepper

Aspiring Daemon

Reaction score: 274
Messages: 797

I think the functionality you're using after is mediated by x11/lxrandr. I would check to see if this was installed and try running it manually. This is essentially a gui front end for xrandr(1). You can specify the resolution in xdm/Xsetup; See Handbook section 5.6. Once set in xdm, the resolution is carried over, unless specifically changed, to your desktop.

Code:
#!/bin/sh
xconsole -geometry 480x100-0-0 -daemon -notify -verbose -fn \
'-schumacher-clean-medium-r-*-*-10-*-*-*-*-*-*-*' -exitOnFail
xrandr ......
 
OP
OP
E

Emrion

Active Member

Reaction score: 40
Messages: 194

Thanks for all the answers.

Sevendogsbsd: I use xfce since years and I have never been obliged to set the resolution with X. I tried Gnome and KDE, I haven't remembrance of such a pain to keep the screen resolution after logout.

b6s6d6: I'll give it a try. I use xdm because it is the only way I found to log with the keyboard layout set in X. All the others use an US layout, no matter the X settings are. Can't recall if I tested sddm and maybe things changed since these tries.

k.jacker: it's the driver that comes with virtualbox-ose-additions, for it's a VM under... VirtualBox .;) If it was a driver problem, I couldn't launch X or I couldn't set the resolution higher than 800x600 and it's not the case. Read carefully below.

shepper: lxrandr is well installed and is working as far as I know. The resolution change inside lxde is working. It's just when I log out and in: the right resolution comes during less than a second, then the default X screen resolution is applied. If no X conf file has been set, it's 800x600.
 
Last edited:

balanga

Son of Beastie

Reaction score: 137
Messages: 3,059

I use LXDE, but one thing I have been unable to make work is auto starting various programs...

This is what I have in .config/lxpanel/LXDE/autostart

Code:
@xfce4-terminal
@chrome
but it doesn't work for me.
 

Trihexagonal

Daemon

Reaction score: 878
Messages: 1,509

Another annoying thing is the creation of an application shortcut on the desktop. Again, very easy to do (just drag and drop an item from the main menu) but when I double-click on the shortcut, a message windows asks "The text file ... seems to be an executable script. What do you want to do with it?". Then, you have to click on "execute" button to launch the said application. I found no way to get rid of this warning (no permission problem, no results in modifing the shortcut file which is actually a text file).

And it's just my first day with lxde. So beautiful, so annoying... Is there somewhere a documentation I shall read before I delete this and shift to another desktop environment?
All the text files I save to USB stick come back off as executables. x11-fm/xfe has an "open with" option you can right-click to select a program to open a specific file. Mine open fine with editors/leafpad.

If I was going to use a DE it would be LXDE. I prefer x11-wm/fluxbox. Everything is brought up from a small right-click menu. Desktop icons remind me of Windows.
 

scottro

Daemon

Reaction score: 501
Messages: 1,411

LXDE uses openbox as its window manager, but you can change that fluxbox. (I've forgotten how, I only played with it. I also prefer window managers to desktop environments--lots less to go wrong).

I do remember with openbox having issues having tint2 autostart. In the end, my working autostart.sh sleeps for 3 seconds then starts tint2.

Code:
(sleep 3 && tint2) &
I'm not sure how lxde sets things up but as it uses openbox, maybe you can use the autostart.sh like that? In openbox's case, it's in $HOME/.config/openbox/autostart.sh
 

shepper

Aspiring Daemon

Reaction score: 274
Messages: 797

do remember with openbox having issues having tint2 autostart. In the end, my working autostart.sh sleeps for 3 seconds then starts tint2.
I'm not sure when, but OpenBox migrated ~/.config/openbox/autostart.sh -> ~/.config/openbox/autostart. Sequencing and some sleep delays are also needed. For example, a systemtray audio volume app (gvolwheel) needs to be started after the tint2 systemtray. In LXDE, lxpanel is used in lieu of tint2.
 
OP
OP
E

Emrion

Active Member

Reaction score: 40
Messages: 194

I tried lxqt. I had to switch to "latest" repository because the lxqt meta port isn't present in "quaterly" one.

Concerning the screen resolution setting, it works (change remains after logout). Better: at the first launch, it guessed the optimum resolution and automatically selected it.

However, there is no hope for desktop shortcut: always the same dumb question when I double-click on it.

Generally speaking, it's rather ugly if I compare to LXDE. Well, I have to dig a little again and/or try to change the windows manager.
 

b6s6d6

Member

Reaction score: 15
Messages: 36

I tried lxqt. I had to switch to "latest" repository because the lxqt meta port isn't present in "quaterly" one.

Concerning the screen resolution setting, it works (change remains after logout). Better: at the first launch, it guessed the optimum resolution and automatically selected it.

However, there is no hope for desktop shortcut: always the same dumb question when I double-click on it.

Generally speaking, it's rather ugly if I compare to LXDE. Well, I have to dig a little again and/or try to change the windows manager.
If you want it to look better, try installing the 'breeze' theme:
sudo pkg install plasma5-breeze plasma5-breeze-gtk
Remember to set it as the default under LXQt settings or similar. You can additionally change the openbox theme too as there are many cool themes out there in sites like Box-Look.org
And about the annoying message when opening desktop shortcuts, given PCManFM-Qt manages the desktop in LXQt, you just need to go to pcmanfm-qt preferences and check "Launch executable files without prompt". Logout or reboot and the problem should be gone
 
Top