A tablet running FreeBSD?

aragats

Daemon

Reaction score: 703
Messages: 1,618

Does anybody have experience running FreeBSD on a tablet?
Any suggestions on brands, chipsets etc?

Thanks!
 

Phishfry

Beastie's Twin

Reaction score: 2,645
Messages: 5,561

I have been meaning to try a Samsung Slate.
That would be my choice. I tried earlier on a Dell tablet but it uses 32bit UEFI and did not work.
 

k.jacker

Aspiring Daemon

Reaction score: 469
Messages: 740

About 2-3 years ago I bought a Huawai Matebook 12 for my wife's bithday.
It runs Windows 10, has an embedded Broadwell Generation Intel Core i5, 8GiB RAM and 256GiB SSD.
It has a detachable keyboard that can wrap the tablet like a cover and acts like a stand when typing.
Secureboot can be disabled by holding vol+ on the tablet when booting up. Then you are presented with a nice BIOS where one could also enable booting via USB.
I had FreeBSD 11.2-RELEASE installed on a external USB harddisk for a while and it ran like a charm.
Fast, silent and cool to the touch.

I think Huawei did a very good job here. No bloatware, not locked down in any way.
Only downside is, that by now, the WiFi device is not supported (Atheros something) and can't be swapped (neither can the SSD or battery) and there is no ethernet port. It only has a single USB-C connector for charging or connecting other devices.
It even suspends/resumes well.
I can't recall if I actually installed Xorg, but it's Broadwell generation GPU (should be some HD5x00) is supported by drm-kmod.
With a USB-C docking that provides some more ports, this little thing will possibly turn in a fully functional device, but sadly I do not own one.
...and another downside is (was) the price at 16000 Norwegian Krones (about 1600 EUR or 1750 US$)

Edit:
It's the first generation MateBook (12")
https://www.amazon.com/Huawei-MateBook-Signature-Tablet-Champagne/dp/B01HSTM436?th=1
 

Trihexagonal

Son of Beastie

Reaction score: 2,287
Messages: 2,854

http://www.thinkwiki.org/wiki/Category:X61_Tablet :)

Not sure if anyone has ever installed FreeBSD on one of these though, but I'd give it a try if a got one.

I had a Thinkpad X61 running FreeBSD that served as my .mp3 player till the fan threw an error on boot and shut it down.

They're calling that a tablet but the only difference in mine and that one is the screen swivels on it and mine had a better CPU. The footprint and screen are the same size and what I considered a small laptop. And a very nice .mp3 player.

 

blackhaz

Active Member

Reaction score: 70
Messages: 176

X1 Yoga here, yes. Everything runs fine except that the stylus isn't working after sleep/resume, and the SD reader is not working. But when the stylus is working it's fun, especially with Kreta! All other functions work well.
 
OP
aragats

aragats

Daemon

Reaction score: 703
Messages: 1,618

Thanks!
I agree with Trihexagonal , all those Thinkpads are actually laptops and pretty expensive.
I have a couple of MS Surface 3 Pro, and I can boot them off a FreeBSD USB stick, but then they freeze because of ACPI and other things. Maybe it's worth investigating.
 

Trihexagonal

Son of Beastie

Reaction score: 2,287
Messages: 2,854

I think I paid $110 for mine from a private seller on ebay. You can tell it's had very light use. I ran it 24/7 for well over a year and have a screenshot of it at 306 days uptime:

the_red_and_the_black.png

I figure I got my moneys worth out of it and would buy another in a heartbeat but the last thing I need is another laptop. :p
 
OP
aragats

aragats

Daemon

Reaction score: 703
Messages: 1,618

I was able to install TrueOS in an MS Surface 3 pro using external keyboard.
The own keyboard doesn't work, but the touchpad does!
Below is the output of pciconf -v.
By my understanding Marvell 88W8897 is not supported...
Code:
hostb0@pci0:0:0:0:  class=0x060000 card=0x00091414 chip=0x22808086 rev=0x20 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register'
    class      = bridge
    subclass   = HOST-PCI
vgapci0@pci0:0:2:0: class=0x030000 card=0x00091414 chip=0x22b08086 rev=0x20 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers'
    class      = display
    subclass   = VGA
none0@pci0:0:3:0:   class=0x048000 card=0x00091414 chip=0x22b88086 rev=0x20 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit'
    class      = multimedia
none1@pci0:0:11:0:  class=0x118000 card=0x00091414 chip=0x22dc8086 rev=0x20 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller'
    class      = dasp
xhci0@pci0:0:20:0:  class=0x0c0330 card=0x72708086 chip=0x22b58086 rev=0x20 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller'
    class      = serial bus
    subclass   = USB
none2@pci0:0:26:0:  class=0x108000 card=0x72708086 chip=0x22988086 rev=0x20 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine'
    class      = encrypt/decrypt
pcib1@pci0:0:28:0:  class=0x060400 card=0x72708086 chip=0x22c88086 rev=0x20 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = 'Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Express Port'
    class      = bridge
    subclass   = PCI-PCI
isab0@pci0:0:31:0:  class=0x060100 card=0x72708086 chip=0x229c8086 rev=0x20 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU'
    class      = bridge
    subclass   = PCI-ISA

none3@pci0:1:0:0:   class=0x020000 card=0x045e0002 chip=0x2b3811ab rev=0x00 hdr=0x00
    vendor     = 'Marvell Technology Group Ltd.'
    device     = '88W8897 [AVASTAR] 802.11ac Wireless'
    class      = network
    subclass   = ethernet
 

tingo

Son of Beastie

Reaction score: 633
Messages: 2,535

I also tried installing FreeBSD on an Acer Iconia Tab W511 back in 2013, but tripped on that 32-bit UEFI. Maybe I should retry this now, to see if anything has changed?
 

Phishfry

Beastie's Twin

Reaction score: 2,645
Messages: 5,561

No tingo nothing changed. Even on Linux most off the shelf distros will not boot fron EFI 32 bit. (Z27xx,Z37xx cpu's)
There is a custom Ubuntu that will.

I have refined my choices for a used tablet. I really want 4G on my next tablet.
Toshiba Q552
Lenovo Thinkpad 10 Gen2
Samsung Slate XE700T1C

I had HP ElitePad on my list but no USB makes that a bad choice.
 

Phishfry

Beastie's Twin

Reaction score: 2,645
Messages: 5,561

That is hilarious. I just traded my Dell ST2 Tablet with Z2765 for an older Dell ST Tablet with Z670 cpu.
32bit CPU but with docking station.

I also just bought a Dell Venue 11 Pro.
It ticked all my boxes.
M.2 Socketed WiFi slot (Intel 73xx card stock but I have an Atheros module to test)
M.2 Socketed WWAN slot (No radio installed in mine but pre-wired with antennas)
M.2 Socketed mSATA
The Venue 11 Pro Model 7140 with M5Y70 only uses 4.5W (Scores 2912)
Dell Venue 11 Pro Model 7130/7139 with 4300Y uses 11.5W (Scores 2500)
So I am glad I took my time and did some homework on these 4G capible models. Same tablet has many variances.

I will report back with my findings.
 

Phishfry

Beastie's Twin

Reaction score: 2,645
Messages: 5,561

-Dell Tablet Report-

OK my Dell Venue Pro 11 just hit the door. Legacy BIOS choice in BIOS and uses 64Bit CPU and 64Bit UEFI.
Bought a brand new dock for $26 bucks with power adapter included.
Booted up to FreeBSD 12-STABLE and I got to the Install screen.
So this one will work for at least command prompt usage. Hopefully a desktop is possible.

In the meanwhile I can update my older Dell Tablet findings.
So I traded my Dell Lattitude ST2 tablet with Z2760 (32 bit CPU with 32 Bit UEFI)
They are unusable on anything but Windows 8 and 10.
Uses fixed eMMC and one half length MiniPCIe slot for WiFi.

Got a Dell Lattitude ST with Z670 (32 bit CPU with Legacy BIOS) and that boots to mountroot>
Did not have time to debug as machine is flaky and died on me. I bought a replacement motherboard to add 4G slot.
Very poor/minimal cooling pipe on this first generation Dell tablet.
Pros: mSATA slot (full length), MiniPCIe slot (half length), 4G version board uses a MiniPCIe slot (full length)

The Dell Lattitude ST2e uses a Z2760 (32Bit UEFI and 32 bit CPU).
This is not usable with FreeBSD or anything but Windows..

So the only thing I want to try now is 8" Dell Venue tablet.
These might not work with FreeBSD because most use a Z3735 (32 Bit UEFI and 64 Bit CPU)

I also want to try a Z8300/Z8500/Z8700 64 bit Tablet CPU. These are slightly newer and use 64bit UEFI.
There is a newer version of the Dell Venue 8 Pro model#5855 that uses the Z8500 CPU.
 

Phishfry

Beastie's Twin

Reaction score: 2,645
Messages: 5,561

Got Xfce4 up and running now researching touchscreen drivers. I have iichid when I looked at what a working Xubuntu was using.

Everything runs fine except that the stylus isn't working after sleep/resume,
Can you share some details of this? Are you using the ig4 driver? HID over i2c device?
There is a phab up with work.
I saw this and it seemed like something you could try:
For now, I solved this problem by adding kldunload ig4 in /etc/rc.suspend and all commands activating touchpad in /etc/rc.resume. With this hack, I have working touchpad after resume, which is very nice.
 

Mjölnir

Daemon

Reaction score: 1,509
Messages: 2,114

I would be interested to get FreeBSD on a PineTab running. Any other of their devices, too (esp. the phone).
For a tablet and phone I'd prefer KDE, but naturally there should be a clean separation to the base system and cooperation of different GUIs a la freedesktop.org
Anyone interested please drop me a note.
 
Top