7.2 install hangs on Lenovo thinkpad x31

Hi all,

I'm new to freebsd, but have been working with linux for a few years now.
I'm trying to install freebsd 7.2 on an old Lenovo thinkpad x31, and for that i'm using a Lenovo usb cd.

At first, boot up would hang after detecting ad0. Then, I booted with acpi disabled, which worked, and it loaded the installer.
The problem is that it hangs while I'm trying to select the country (IE, the first item on the installer). I start scrolling for a few seconds, and then it gets stuck, and i have to reset.

Any ideas?
 
Update:
I tried the bootonly cd, hoping to install from ftp and that it's just a media problem, but it happens there too...
 
This is not going to be a definitive reply, more of a guess. In my experience, one of the few weak spots of FreeBSD is its support for USB devices. Testament to the problems with USB is the fact that the whole USB subsystem has been re-written for the upcoming 8.0 release. So my guess is that your problem is attempting to install from a badly supported USB CD device. Again, I would like to emphasize that this is speculation on my part, having had my own problems with FreeBSD talking to SATA drives in USB shoeboxes, which I use for backups (I have had so many problems -- system crashes -- trying to do backups directly to these drives that I uninstalled FreeBSD from one of my systems, replaced it with Arch Linux, rsync my home directory from my main system running FreeBSD to the Linux system, and then rsync my home directory from there to the USB backup drive; I periodically tar up everything but my home directory to the backup drive; this I do on the FreeBSD systems by booting an Arch Linux LiveCD and running a backup script on the USB drive).

If I were in your shoes, I'd probably wait for 8.0 to try to install FreeBSD, unless you have access to an atapi or scsi CD drive.

/Don Allen
 
donallen said:
If I were in your shoes, I'd probably wait for 8.0 to try to install FreeBSD, unless you have access to an atapi or scsi CD drive.

/Don Allen

The thinkpad x31 doesn't have a build-in cd-rom. AFAIK, the only way to get it to work with a CD is by using a usb device.
I really need to work with a BSD style system on this laptop for work-related reasons.
Really has no one tried and succeeded installing freeBSD on a thinkpad before?

Is there any other way to install freebsd on this laptop?
 
If the CD doesn't work, the DVD isn't likely to either, in my opinion.

If you can get your hands on a USB floppy drive, you might try that (see the installation documentation; installing from floppies is supported), just to get the system booted and then do the install over the network. The lower bandwidth of the floppy drive, as compared to CD drive, might allow the shaky USB stuff to work. Again, I emphasize that I'm guessing here, trying to give you some ideas to get you going.

/Don Allen
 
I've managed to install openbsd in the meantime. Installation went pretty smoothly.
I hope FreeBSD will pick up the slack when it comes to HW support.

Thanks anyway.
 
In case you ever would be in a new attempt to install FreeBSD on this laptop:

If you have access to a DOS system and the laptop's HD can be easily removed (should be the case for Thinkpads), you could try installing from a DOS partition. The procedure is covered in the online FreeBSD handbook.

I don't remember the details very well, but it worked out very good for me in the past. I have installed FreeBSD on several laptops (Thinkpad 760, Palmax, ...) lacking USB, CD-ROM and network this way.
 
Top