1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

POST hangs with USB disk

Discussion in 'Peripheral Hardware' started by arkive, Feb 25, 2010.

  1. arkive

    arkive New Member

    Messages:
    9
    Thanks Received:
    0
    I've installed FreeBSD 8.0 Release i386 bootonly cd (over ftp passive) with a USB CD-Rom to a USB Disk. There were no errors during the install, as far as I can tell. After rebooting with the USB Disk plugged into any USB port the system does not boot. If the partitions are delete on the USB Disk the system POSTs fine. What is it about FreeBSD 8.0 that would cause this? UFS?
     
  2. Carpetsmoker

    Carpetsmoker Member

    Messages:
    943
    Thanks Received:
    136
    Disable "USB Legacy support" in your BIOS, this usually fixes the problem.
     
  3. arkive

    arkive New Member

    Messages:
    9
    Thanks Received:
    0
    I've tried disabling usb legacy support, no dice. what would explain the system being able to POST with a FAT16 or no filesystem? is it possible to have freebsd boot from a FAT16 filesystem?
     
  4. arkive

    arkive New Member

    Messages:
    9
    Thanks Received:
    0
    with the same USB disk the system posts fine and boots with Ubuntu on the USB Disk. I believe they use FAT32.

    Code:
    $ sudo fdisk -l /dev/sdb
    
    Disk /dev/sdb: 8015 MB, 8015282176 bytes
    247 heads, 62 sectors/track, 1022 cylinders
    Units = cylinders of 15314 * 512 = 7840768 bytes
    Disk identifier: 0x0007260c
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *           1        1022     7825423    c  W95 FAT32 (LBA)
     
  5. Carpetsmoker

    Carpetsmoker Member

    Messages:
    943
    Thanks Received:
    136
    If your system hangs at POST then I doubt it has something to do with the filesystem ...

    Maybe your system hangs at some post-POST stage, for example at the USB disk's bootloader?
     
  6. fbsd1

    fbsd1 New Member

    Messages:
    213
    Thanks Received:
    47
    Freebsd can not be installed to a MS partition. Using sysinstall you have to delete the allocated ms/partition and allocate a freebsd slice and then allocate the file systems in that slice.
     
  7. arkive

    arkive New Member

    Messages:
    9
    Thanks Received:
    0
    It's during POST when the system hangs. If FreeBSD is installed on the USB disk (with either of the boot loader options installed) the system never beeps, it never finishes POST. If Ubuntu Linux (FAT32 and Grub?) or a plain FAT filesystem is on the USB Disk the system works fine.