1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Openoffice.org-3 Package

Discussion in 'Installation and Maintenance of Ports or Packages' started by Xaenn, Dec 17, 2008.

  1. Xaenn

    Xaenn New Member

    Messages:
    9
    Likes Received:
    0
    Hello all,

    I'm having problems with the openoffice.org-3 package from good day: ftp://ooopackages.good-day.net/pub/OpenOffice.org/FreeBSD/3.0.0/i386

    After I try to start openoffice I get the following message:

    bsd% openoffice.org-3.0.0
    The application cannot be started.
    The component manager is not available.
    Segmentation fault

    I've tried running it with jdk16 and without, but either way I cannot get it to run properly. Suggestions and advice greatly welcomed.

    Regards,
    -Xaenn
     
  2. VitalyMoiseev

    VitalyMoiseev New Member

    Messages:
    12
    Likes Received:
    0
    i have OO3 compiled from ports
    work fine!
     
  3. kamikaze

    kamikaze New Member

    Messages:
    366
    Likes Received:
    0
    You should check the integrity of your installation:

    # pkg_info -gx openoffice
     
  4. Xaenn

    Xaenn New Member

    Messages:
    9
    Likes Received:
    0
    I must apologize for my very bad forum etiquette - I posted this message just before I was going to be away from my computer for 3 weeks.

    Unfortunately I have quite a slow old machine so compiling OO3 from source really isn't an option.

    I did so, and had the following results:

    Code:
    bsd# pkg_info -gx en-openoffice.org-US-3.0.0
    Information for en-openoffice.org-US-3.0.0:
    
    Mismatched Checksums:
    
    bsd# 
    Which seems to indicate there is no problem. Any other ideas?
     
  5. kamikaze

    kamikaze New Member

    Messages:
    366
    Likes Received:
    0
    Did you install it with [cmd=pkg_add]-f[/cmd]? Were there any missing dependencies?
     
  6. Xaenn

    Xaenn New Member

    Messages:
    9
    Likes Received:
    0
    I did have to use pkg_add -f, as usual, but I didn't really notice anything that seemed too disconcerting.

    Code:
    bsd# pkg_add -f ~xaenn/OOo_3.0.0_FreeBSD71Intel_install_en-US.tbz 
    pkg_add: warning: package 'en-openoffice.org-US-3.0.0' requires 'dmidecode-2.9', but 'dmidecode-2.10' is installed
    pkg_add: warning: package 'en-openoffice.org-US-3.0.0' requires 'png-1.2.33', but 'png-1.2.34' is installed
    pkg_add: warning: package 'en-openoffice.org-US-3.0.0' requires 'xcb-util-0.2.1', but 'xcb-util-0.3.0' is installed
    pkg_add: warning: package 'en-openoffice.org-US-3.0.0' requires 'cairo-1.6.4_3,1', but 'cairo-1.6.4_4,1' is installed
    pkg_add: warning: package 'en-openoffice.org-US-3.0.0' requires 'samba-libsmbclient-3.0.32_1', but 'samba-libsmbclient-3.0.32_3' is installed
    pkg_add: warning: package 'en-openoffice.org-US-3.0.0' requires 'glib-2.16.5', but 'glib-2.16.5_1' is installed
    pkg_add: warning: package 'en-openoffice.org-US-3.0.0' requires 'avahi-app-0.6.23', but 'avahi-app-0.6.24' is installed
    pkg_add: warning: package 'en-openoffice.org-US-3.0.0' requires 'libIDL-0.8.11', but 'libIDL-0.8.12' is installed
    pkg_add: warning: package 'en-openoffice.org-US-3.0.0' requires 'libgcrypt-1.4.1_1', but 'libgcrypt-1.4.3' is installed
    pkg_add: warning: package 'en-openoffice.org-US-3.0.0' requires 'gnutls-2.4.2_1', but 'gnutls-2.6.3' is installed
    pkg_add: warning: package 'en-openoffice.org-US-3.0.0' requires 'cups-base-1.3.9', but 'cups-base-1.3.9_2' is installed
    
    OpenOffice.org Build OOO300_m9 Personal Install How-To
    
    Written by:     Martin Blapp <mbr@freebsd.org>
                    and Maho Nakata <maho@FreeBSD.org>
    
    OpenOffice.org OOO300_m9 will soon been installed in
    /usr/local/openoffice.org-3.0.0
    
    ...
    [\code]
     
  7. kamikaze

    kamikaze New Member

    Messages:
    366
    Likes Received:
    0
    There have been library changes recently that affect dependencies of OpenOffice.org, if you install sysutils/bsdadminscripts (it has no dependencies), you can run # pkg_libchk and show us the output. This might give a clue.
     
  8. Xaenn

    Xaenn New Member

    Messages:
    9
    Likes Received:
    0
    I went through and ran
    Code:
    pkg_libchk
    , but unfortunately it didn't find anything. After completing execution I was simply left with a blank prompt, and no output messages.
     
  9. kamikaze

    kamikaze New Member

    Messages:
    366
    Likes Received:
    0
    Honestly? OpenOffice always yields something unless you have certain entries in your /etc/libmap.conf. Do you?

    This is rather strange.
     
  10. Xaenn

    Xaenn New Member

    Messages:
    9
    Likes Received:
    0
    Just to make sure I went ahead and ran
    Code:
    pkg_libchk en-openoffice.org-US-3.0.0
    but I still didn't have any output. Checking /etc/libmap.conf I found an empty file. Thanks for working through this with my despite no resolution thus far.
     
  11. kamikaze

    kamikaze New Member

    Messages:
    366
    Likes Received:
    0
    Try that one:
    # pkg_libchk -r en-openoffice.org-US-3.0.0
     
  12. Xaenn

    Xaenn New Member

    Messages:
    9
    Likes Received:
    0
    That is a little better. I find it odd that I got no output when I ran without any flags (which went through all packages), but nevertheless, here is what I have got:

    Code:
    bsd# pkg_libchk -r en-openoffice.org-US-3.0.0
    pkg_info: can't find package 'dmidecode-2.9' installed or in a file!
    pkg_info: can't find package 'png-1.2.33' installed or in a file!
    pkg_info: can't find package 'xcb-util-0.2.1' installed or in a file!
    pkg_info: can't find package 'cairo-1.6.4_3,1' installed or in a file!
    pkg_info: can't find package 'samba-libsmbclient-3.0.32_1' installed or in a file!
    pkg_info: can't find package 'glib-2.16.5' installed or in a file!
    pkg_info: can't find package 'avahi-app-0.6.23' installed or in a file!
    pkg_info: can't find package 'libIDL-0.8.11' installed or in a file!
    pkg_info: can't find package 'libgcrypt-1.4.1_1' installed or in a file!
    pkg_info: can't find package 'gnutls-2.4.2_1' installed or in a file!
    pkg_info: can't find package 'cups-base-1.3.9' installed or in a file!
    
     
  13. kamikaze

    kamikaze New Member

    Messages:
    366
    Likes Received:
    0
    Depending on weather you use portupgrade or portmaster you should run one of these commands:

    # portmaster --check-depends
    # pkgdb -F (for portupgrade)

    You should install those dependencies that cannot be mapped to newer versions. This will lead to a consistent package database. Unfortunately it will not fix your problem unless there are actually missing dependencies.
     
  14. Xaenn

    Xaenn New Member

    Messages:
    9
    Likes Received:
    0
    Fortunately (or unfortunately) I wasn't actually missing any of the packages - I just had newer versions. Nevertheless, the problem has been solved, although rather inadvertently. I just updated to FreeBSD 7.1 so that I could get flash9 working, and since doing so openoffice.org-3 also happily starts up. This isn't extremely satisfying because I don't know exactly what the problem ever was, but I am happy to have the program itself working.
     
  15. kamikaze

    kamikaze New Member

    Messages:
    366
    Likes Received:
    0
    I think I recall there have been compatibility breaking library changes between 7.0 and 7.1 that were necessary to address a security problem. That might have been the source of your problem.