1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

make install fatal error? make.conf

Discussion in 'Installation and Maintenance of Ports or Packages' started by eggblade1, Oct 24, 2012.

  1. eggblade1

    eggblade1 New Member

    Messages:
    14
    Thanks Received:
    0
    Hello, I'm reflectively new to FreeBSD and UNIX-like OS's so my troubleshooting techniques are almost non-existent...

    Today, I am trying to install an FTP server to go along with my newly made webserver. Followed a guide on installing vsftpd and got this error right off the start:
    Code:
    # cd /usr/ports/ftp/vsftpd
    # make install clean
    "/etc/make.conf", line 3: .include filename must be delimited by '"' or '<'
    make: fatal errors encountered -- cannot continue
    


    This is what my make.conf file looks like, I looked at examples on line and nobody's make.conf was in any way similar to mine:

    Code:
    # added by use.perl 2012-10-23 03:11:58
    PERL_VERSION=5.14.1
    .include /usr/local/etc/ports_sites.conf
    


    I guess you see I have installed perl. Not sure why it is displayed here and nothing else installed.

    Critical information: on accident, I ran the command portsnap extract when trying to update my ports collection. I intended to type portsnap update

    What can I do to correct the problem?

    Thanks ahead of time.
     
  2. eggblade1

    eggblade1 New Member

    Messages:
    14
    Thanks Received:
    0
    :q

    so I did what the error told me to do and edited make.conf
    Code:
    line 3:
    .include "/usr/local/etc/ports_sites.conf"
    

    seems to be working. I installed Pure-FTP because vsftpd was no longer on the ports list.

    Waiting for feedback. In the mean time, installing pure-ftp. :q

    Just very confused as to why this happened and why I can no longer see vsftpd.

    :q:q:q:q
     
  3. eggblade1

    eggblade1 New Member

    Messages:
    14
    Thanks Received:
    0
    Sorry for the triple posting. It seems as though I am unable to edit my own posts.

    Additional Information: Just remembered that I installed the port Fastest Sites from ports-mgmt/fastest_sites

    HAH! Just found my problem. A guide I followed from here had me edit my make.conf file. I (being stupid) just copy and pasted all of his code.

    It Pays to not be mindless and do the work yourself.

    ---Thread Closed---
     
  4. SirDice

    SirDice Moderator Staff Member Moderator

    Messages:
    17,628
    Thanks Received:
    2,385
    Read your signup email.