1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issues updating to openssl-0.9.8j

Discussion in 'Installing and Upgrading FreeBSD' started by boga, Jan 14, 2009.

  1. boga

    boga New Member

    Messages:
    3
    Likes Received:
    0
    I have an issue update openssl to 0.9.8j from 0.9.8i.

    the system I am using is a Web Server without much on it ... so no X. I do also have configured my /etc/portsnap.conf to ignore/refuse x11 (so don't extract this packages).

    Now updating to the latest release of openssl gives me following error:

    portupgrade -a
    ---> Upgrading 'openssl-0.9.8i' to 'openssl-0.9.8j' (security/openssl)
    ---> Building '/usr/ports/security/openssl'
    openssl-0.9.8j: "/usr/ports/x11/xproto" non-existent -- dependency list incomplete
    ===> Cleaning for makedepend-1.0.1,1
    ===> Cleaning for openssl-0.9.8j
    ===> Vulnerability check disabled, database not found
    ===> Extracting for openssl-0.9.8j
    => MD5 Checksum OK for openssl-0.9.8j.tar.gz.
    cd /usr po sec


    checking for X... gnome-config: not found
    configure: error: Package requirements (xproto) were not met.
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively you may set the X_CFLAGS and X_LIBS environment variables
    to avoid the need to call pkg-config. See the pkg-config man page for
    more details.
    ===> Script "configure" failed unexpectedly.
    Please report the problem to x11@FreeBSD.org [maintainer] and attach the
    "/usr/ports/devel/makedepend/work/makedepend-1.0.1/config.log" including the
    output of the failure of your make command. Also, it might be a good idea to
    provide an overview of all packages installed on your system (e.g. an `ls
    /var/db/pkg`).
    *** Error code 1

    Stop in /usr/ports/devel/makedepend.
    *** Error code 1

    Stop in /usr/ports/security/openssl.
    ** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.82899.0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=openssl-0.9.8i UPGRADE_PORT_VER=0.9.8i make
    ** Fix the problem and try again.
    ** Listing the failed packages (-:ignored / *:skipped / !:failed)
    ! security/openssl (openssl-0.9.8i) (configure error)



    Is there a switch i can use to openssl doesn't check for x packages?


    This is a FreeBSD 6.3 amd64 box.

    Feedback is appreciated.
     
  2. beastie_007

    beastie_007 New Member

    Messages:
    15
    Likes Received:
    0
    Now updating to the latest release of openssl gives me following error:

    portupgrade -a
    ---> Upgrading 'openssl-0.9.8i' to 'openssl-0.9.8j' (security/openssl)
    ---> Building '/usr/ports/security/openssl'
    openssl-0.9.8j: "/usr/ports/x11/xproto" non-existent -- dependency list incomplete
    ===> Cleaning for makedepend-1.0.1,1
    ===> Cleaning for openssl-0.9.8j
    ===> Vulnerability check disabled, database not found
    ===> Extracting for openssl-0.9.8j
    => MD5 Checksum OK for openssl-0.9.8j.tar.gz.
    cd /usr po sec

    Maybe using portmaster could be an better solution, ..
    command:
    portmaster -L | grep -B1 "New version"
    after a while you will see a message like there is a newer version.
    another option is to deinstall and than reinstall agian.

    ....But , you know ....i am a newbie with freebsd
    (and learning now on FreeBSD)

    i am an old debian GNU/Linux user ;-)
    but still working on it beside a beastie_box (multi_boot)

    good luck,
    beastie_007
     
  3. cajunman4life

    cajunman4life New Member

    Messages:
    119
    Likes Received:
    0
    Try setting:

    WITHOUT_X11=yes

    in /etc/make.conf. I have this setting for my servers (which also don't run X).
     
  4. phantomcircuit

    phantomcircuit New Member

    Messages:
    6
    Likes Received:
    0
    I'm having the same problem and I do have WITHOUT_X11 in /etc/make.conf

    Code:
    # make
    ===>   openssl-0.9.8j depends on executable: makedepend - not found
    ===>    Verifying install for makedepend in /usr/ports/devel/makedepend
    ===>   makedepend-1.0.1,1 depends on file: /usr/local/libdata/pkgconfig/xproto.pc - not found
    ===>    Verifying install for /usr/local/libdata/pkgconfig/xproto.pc in /usr/ports/x11/xproto
         => No directory for /usr/local/libdata/pkgconfig/xproto.pc.  Skipping..
    ===>   makedepend-1.0.1,1 depends on executable: pkg-config - found
    ===>  Configuring for makedepend-1.0.1,1
    checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
    checking whether build environment is sane... yes
    checking for gawk... no
    checking for mawk... no
    checking for nawk... nawk
    checking whether make sets $(MAKE)... yes
    checking for gcc... cc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables... 
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether cc accepts -g... yes
    checking for cc option to accept ANSI C... none needed
    checking for style of include used by make... GNU
    checking dependency style of cc... gcc3
    checking return type of signal handlers... void
    checking for rename... yes
    checking for fchmod... yes
    checking for special C compiler options needed for large files... no
    checking for _FILE_OFFSET_BITS value needed for large files... no
    checking for _LARGE_FILES value needed for large files... no
    checking for pkg-config... /usr/local/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for X... gnome-config: not found
    configure: error: Package requirements (xproto) were not met.
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.
    
    Alternatively you may set the X_CFLAGS and X_LIBS environment variables
    to avoid the need to call pkg-config.  See the pkg-config man page for
    more details.
    ===>  Script "configure" failed unexpectedly.
    Please report the problem to x11@FreeBSD.org [maintainer] and attach the
    "/usr/ports/devel/makedepend/work/makedepend-1.0.1/config.log" including the
    output of the failure of your make command. Also, it might be a good idea to
    provide an overview of all packages installed on your system (e.g. an `ls
    /var/db/pkg`).
    *** Error code 1
    
    Stop in /usr/ports/devel/makedepend.
    *** Error code 1
    
    Stop in /usr/ports/security/openssl.
    
     
  5. boga

    boga New Member

    Messages:
    3
    Likes Received:
    0
    I do have WITHOUT_X11=yes already in my make.conf ... that is also why i just don't know why openssl is checking for x.
     
  6. RSecor

    RSecor New Member

    Messages:
    3
    Likes Received:
    0