1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Getting Xorg to work on FreeBSD 8.0 in VMware

Discussion in 'X.Org' started by pommonico, Nov 28, 2009.

  1. pommonico

    pommonico New Member

    Messages:
    2
    Likes Received:
    0
    Hello folks.

    I have installed FreeBSD 8.0 on VMware Fusion 3 on a Mac. Did a pkg_add to install xorg and also xf86-video-vmware.

    When I try to start X with startx, I see TWM started with some xterm's, but I cannot type and I cannot move the mouse (but my mouse works in text mode).

    I've also tried X -configure followed by X -config xorg.conf.new. If I do this, all I get is a blank window.

    Anyone else try this combination and got it to work?
     
  2. pommonico

    pommonico New Member

    Messages:
    2
    Likes Received:
    0
    Made some progress. Added hald_enabled="YES" to /etc/rc.conf based on a blog suggestion and X now starts, but with a very small resolution. Again, if I try to create my own configuration using X -configure, the result is a blank screen, which means that I'm unable to change resolution. This is really rather frustrating.
     
  3. buwei

    buwei New Member

    Messages:
    2
    Likes Received:
    0
    xorg.conf

    Code:
    Section "ServerFlags"
    Option "AllowEmptyInput" "False"
    EndSection
     
  4. adamk

    adamk New Member

    Messages:
    1,624
    Likes Received:
    0
    Unless you use the -retro option, all you will ever get these days is a blank window.

    Adam
     
  5. FBSDin20Steps

    FBSDin20Steps New Member

    Messages:
    283
    Likes Received:
    0
    Take a look here