KDE4 localization

The K Desktop Environment

KDE4 localization

Postby malic » 07 Dec 2009, 10:19

Hi,

I installed KDE4 from ports and installed the ports for french localization kde4-l10n.
Seem right, I can select French language in KDE 4 config but after a relog, half the messages are correctly translated.
Typically when I right click on the desktop, instead of "Desktop settings" I have "Bureau settings".

Does anyone have such problems with KDE4 localization?
Or an idea why localization doesn't apply correctly?

I'm on 8.0 btw.

Malic
malic
Junior Member
 
Posts: 10
Joined: 25 Jun 2009, 09:16

Postby avilla@ » 07 Dec 2009, 11:21

perhaps they are incomplete...?
Alberto Villa, FreeBSD committer <avilla@FreeBSD.org>
http://people.FreeBSD.org/~avilla
User avatar
avilla@
Member
 
Posts: 258
Joined: 04 Jul 2009, 16:51
Location: Italy

Postby graudeejs » 07 Dec 2009, 14:11

Sorry, I can't help, but I wanted to say:

This is exactly why I use apps in English exclusively :D
User avatar
graudeejs
Style(9) Addict
 
Posts: 4591
Joined: 16 Nov 2008, 23:23
Location: Riga, Latvia

Postby malic » 07 Dec 2009, 14:40

Yeah, I don't bother that much using it in en-US but as I'm not the only one to use the computer and she's pretty much used to Linux/KDE4 in french, this extra effort could get me rid of Linux.

Going to compare the KDE4 version from Linux to FreeBSD to see.
malic
Junior Member
 
Posts: 10
Joined: 25 Jun 2009, 09:16

Postby graudeejs » 07 Dec 2009, 15:35

You should try try to set locale environment variables....
Code: Select all
LANG="en_GB.UTF-8"
LC_COLLATE="lv_LV.UTF-8"
LC_CTYPE="lv_LV.UTF-8"
LC_MESSAGES="lv_LV.UTF-8"
LC_MONETARY="lv_LV.UTF-8"
LC_NUMERIC="lv_LV.UTF-8"
LC_TIME="lv_LV.UTF-8"
export LANG LC_COLLATE LC_CTYPE LC_MESSAGES LC_MONETARY LC_NUMERIC LC_TIME


I'm not sure where is the best way to set them to have global effect.... I place them in /etc/csh.cshrc /etc/profile ~/.shrc ~/.cshrc ~/.xinitrc and ~/.xsession

I think if you take a closer look at /etc/login.conf..... you'll see:
Code: Select all
    :setenv=MAIL=/var/mail/$,BLOCKSIZE=K,FTP_PASSIVE_MODE=YES:\

you can set locale variables similarly system wide

It's worth giving a shoot
User avatar
graudeejs
Style(9) Addict
 
Posts: 4591
Joined: 16 Nov 2008, 23:23
Location: Riga, Latvia

Postby malic » 07 Dec 2009, 21:44

You win, Killasmurf....

Tried to setup the login.conf as in the handbook but not a chance.
I add the LANG and LC_ALL to .profile and it worked fine.
Just have to process the $SHELL to set it up in /etc/profile for system wide setting.
malic
Junior Member
 
Posts: 10
Joined: 25 Jun 2009, 09:16

Postby graudeejs » 07 Dec 2009, 21:51

I think [file]/etc/profile[/file] is only read by sh and alike....

I think you need to edit [file]/etc/login.conf[/file] something like this:
Code: Select all
:setenv=MAIL=/var/mail/$,BLOCKSIZE=K,FTP_PASSIVE_MODE=YES,LANG="en_GB.UTF-8",LC_COLLATE="lv_LV.UTF-8",LC_CTYPE="lv_LV.UTF-8",LC_MESSAGES="lv_LV.UTF-8",LC_MONETARY="lv_LV.UTF-8",LC_NUMERIC="lv_LV.UTF-8",LC_TIME="lv_LV.UTF-8":\


or

Code: Select all
:setenv=LANG="en_GB.UTF-8",LC_COLLATE="lv_LV.UTF-8":\
:setenv=LC_CTYPE="lv_LV.UTF-8",LC_MESSAGES="lv_LV.UTF-8":\
:setenv=LC_MONETARY="lv_LV.UTF-8",LC_NUMERIC="lv_LV.UTF-8":\
:setenv=LC_TIME="lv_LV.UTF-8":\


I'm not 100% sure 2nd will work... perhaps you can only use setenv once... I don't know these details, but you can try and use whichever works and you like better
User avatar
graudeejs
Style(9) Addict
 
Posts: 4591
Joined: 16 Nov 2008, 23:23
Location: Riga, Latvia

Postby malic » 08 Dec 2009, 09:25

Yeah, redid a pass on the login.conf et it work by setting a french entry with $LC_ALL and $LANG, I just have to specify in the /etc/passwd for each user.

Well, just right what is written in the handbook.
Damn... 'knew that!

I'll try to change in the default entry to see.
Thanks tho
malic
Junior Member
 
Posts: 10
Joined: 25 Jun 2009, 09:16

Postby graudeejs » 08 Dec 2009, 13:17

No.... you don't have to touch [file]/etc/passwd[/file] at all....
User avatar
graudeejs
Style(9) Addict
 
Posts: 4591
Joined: 16 Nov 2008, 23:23
Location: Riga, Latvia

Postby graudeejs » 08 Dec 2009, 13:24

One more thing.... make sure you run [cmd=#]cap_mkdb[/cmd] after you edit [file]/etc/login.conf[/file]
User avatar
graudeejs
Style(9) Addict
 
Posts: 4591
Joined: 16 Nov 2008, 23:23
Location: Riga, Latvia

Postby graudeejs » 09 Dec 2009, 08:55

Also scroll down login.conf...
you'll see example for russian users.
lang is set there, you can create french user class same way.... only thin you will need to modify user class for user that are created already...
User avatar
graudeejs
Style(9) Addict
 
Posts: 4591
Joined: 16 Nov 2008, 23:23
Location: Riga, Latvia

Postby malic » 09 Dec 2009, 10:21

Yeah, that's exactly what I did.
Created a french user class to specify the language but in that case you have to specify the language in the passwd file (good for me actually)

Shell reply to me in french now... but best of all, KDE4 is fully in french.

Have to try to push the setting in the default class but have little time to give it a go atm.

Thanks for your help.
M

PS : thanks for OpenOffice 3.1.1, too bad I'm a 64bits user.
malic
Junior Member
 
Posts: 10
Joined: 25 Jun 2009, 09:16

Postby graudeejs » 09 Dec 2009, 10:37

malic wrote:PS : thanks for OpenOffice 3.1.1, too bad I'm a 64bits user.


64bit packages
ftp://ooopackages.good-day.net/pub/OpenOffice.org/FreeBSD/
User avatar
graudeejs
Style(9) Addict
 
Posts: 4591
Joined: 16 Nov 2008, 23:23
Location: Riga, Latvia

Postby BeastieBoy » 05 Jul 2010, 10:13

In order for daemons to pick up the locale where whouls LC_TYPE et al. be declared? Not .login_conf?
BeastieBoy
Junior Member
 
Posts: 81
Joined: 26 Jun 2010, 17:11


Return to KDE

Who is online

Users browsing this forum: No registered users and 0 guests