Getting Xorg to work on FreeBSD 8.0 in VMware

X.Org on FreeBSD installation & configuration.

Getting Xorg to work on FreeBSD 8.0 in VMware

Postby pommonico » 28 Nov 2009, 08:21

Hello folks.

I have installed FreeBSD 8.0 on VMware Fusion 3 on a Mac. Did a pkg_add to install xorg and also xf86-video-vmware.

When I try to start X with startx, I see TWM started with some xterm's, but I cannot type and I cannot move the mouse (but my mouse works in text mode).

I've also tried X -configure followed by X -config xorg.conf.new. If I do this, all I get is a blank window.

Anyone else try this combination and got it to work?
pommonico
Junior Member
 
Posts: 2
Joined: 28 Nov 2009, 08:15

Postby pommonico » 28 Nov 2009, 09:03

Made some progress. Added hald_enabled="YES" to /etc/rc.conf based on a blog suggestion and X now starts, but with a very small resolution. Again, if I try to create my own configuration using X -configure, the result is a blank screen, which means that I'm unable to change resolution. This is really rather frustrating.
pommonico
Junior Member
 
Posts: 2
Joined: 28 Nov 2009, 08:15

Postby buwei » 28 Nov 2009, 09:58

xorg.conf

Code: Select all
Section "ServerFlags"
Option "AllowEmptyInput" "False"
EndSection
buwei
Junior Member
 
Posts: 2
Joined: 20 Mar 2009, 00:39

Postby adamk » 28 Nov 2009, 12:18

pommonico wrote:I've also tried X -configure followed by X -config xorg.conf.new. If I do this, all I get is a blank window.



Unless you use the -retro option, all you will ever get these days is a blank window.

Adam
adamk
Senior Member
 
Posts: 1624
Joined: 21 Nov 2008, 11:00

Postby FBSDin20Steps » 28 Nov 2009, 13:28

Take a look here
Greetz ;)
User avatar
FBSDin20Steps
Member
 
Posts: 283
Joined: 03 Mar 2009, 17:01
Location: Barendrecht, The Netherlands


Return to X.Org

Who is online

Users browsing this forum: No registered users and 0 guests