fail in upgrading GNOME

The GNOME desktop environment

fail in upgrading GNOME

Postby SIFE » 07 Oct 2009, 11:21

Salamo Alikom
i got this MSG when i try to upgrade GNOME
Code: Select all
[root@localhost ~]# portmaster -a gnome-
===>>> Gathering distinfo list for installed ports

===>>> Starting check of installed ports for available updates
===>>> Checking ports for recursive 'make config'
===>>> Launching child to update php_doc-en-20090514 to php_doc-en-20090901

===>>> Port directory: /usr/ports/lang/php_doc
===>>> Launching 'make checksum' for lang/php_doc in background
===>>> Gathering dependency list for lang/php_doc from ports
===>>> No dependencies for lang/php_doc
===>>> Returning to update check of installed ports

===>>> Launching child to update chmlib-0.39_2 to chmlib-0.40

===>>> Port directory: /usr/ports/misc/chmlib
===>>> Launching 'make checksum' for misc/chmlib in background
===>>> Gathering dependency list for misc/chmlib from ports
===>>> Starting recursive 'make config' check
===>>> Recursive 'make config' check complete for misc/chmlib

===>>> Returning to update check of installed ports

===>>> Launching child to update fusefs-kmod-0.3.9.p1.20080208_2 to fusefs-kmod-0.3.9.p1.20080208_6

===>>> Port directory: /usr/ports/sysutils/fusefs-kmod
===>>> Launching 'make checksum' for sysutils/fusefs-kmod in background
===>>> Gathering dependency list for sysutils/fusefs-kmod from ports
===>>> Starting recursive 'make config' check
===>>> Launching child to update fusefs-libs-2.7.3 to fusefs-libs-2.7.4
   fusefs-kmod-0.3.9.p1.20080208_2 >> fusefs-libs-2.7.3

===>>> Port directory: /usr/ports/sysutils/fusefs-libs
===>>> Launching 'make checksum' for sysutils/fusefs-libs in background
===>>> Gathering dependency list for sysutils/fusefs-libs from ports
===>>> Starting recursive 'make config' check
===>>> Recursive 'make config' check complete for sysutils/fusefs-libs
   fusefs-kmod-0.3.9.p1.20080208_2 >> fusefs-libs-2.7.3

===>>> Continuing 'make config' dependency check for sysutils/fusefs-kmod
===>>> Launching child to update textproc/ruby-deplate
   fusefs-kmod-0.3.9.p1.20080208_2 >> textproc/ruby-deplate

===>>> Port directory: /usr/ports/textproc/ruby-deplate
===>>> Launching 'make checksum' for textproc/ruby-deplate in background
===>>> Gathering dependency list for textproc/ruby-deplate from ports
===>>> Starting recursive 'make config' check
===>>> Launching child to update ruby-1.8.6.287,1 to ruby-1.8.7.160_4,1
   fusefs-kmod-0.3.9.p1.20080208_2 >> textproc/ruby-deplate >> ruby-1.8.6.287,1

===>>> Port directory: /usr/ports/lang/ruby18
===>>> Gathering dependency list for lang/ruby18 from ports
===>>> Starting recursive 'make config' check
===>>> Recursive 'make config' check complete for lang/ruby18
   fusefs-kmod-0.3.9.p1.20080208_2 >> textproc/ruby-deplate >> ruby-1.8.6.287,1

===>>> Continuing 'make config' dependency check for textproc/ruby-deplate
===>>> Recursive 'make config' check complete for textproc/ruby-deplate
   fusefs-kmod-0.3.9.p1.20080208_2 >> textproc/ruby-deplate

===>>> Continuing 'make config' dependency check for sysutils/fusefs-kmod
===>>> Recursive 'make config' check complete for sysutils/fusefs-kmod

===>>> Returning to update check of installed ports

===>>> Launching child to update gpac-libgpac-0.4.4,1 to gpac-libgpac-0.4.5_2,1

===>>> Port directory: /usr/ports/multimedia/gpac-libgpac
===>>> Launching 'make checksum' for multimedia/gpac-libgpac in background
===>>> Gathering dependency list for multimedia/gpac-libgpac from ports
===>>> Starting recursive 'make config' check
===>>> Launching child to update libGL-7.0.3 to libGL-7.4.4
   gpac-libgpac-0.4.4,1 >> libGL-7.0.3

===>>> Port directory: /usr/ports/graphics/libGL
===>>> Launching 'make checksum' for graphics/libGL in background
===>>> Gathering dependency list for graphics/libGL from ports
===>>> Starting recursive 'make config' check
===>>> Launching child to update libdrm-2.3.1 to libdrm-2.4.12
   gpac-libgpac-0.4.4,1 >> libGL-7.0.3 >> libdrm-2.3.1

===>>> Port directory: /usr/ports/graphics/libdrm
===>>> Launching 'make checksum' for graphics/libdrm in background
===>>> Gathering dependency list for graphics/libdrm from ports
===>>> Starting recursive 'make config' check
===>>> Recursive 'make config' check complete for graphics/libdrm
   gpac-libgpac-0.4.4,1 >> libGL-7.0.3 >> libdrm-2.3.1

===>>> Continuing 'make config' dependency check for graphics/libGL
===>>> Launching child to update libXext-1.0.3,1 to libXext-1.0.5,1
   gpac-libgpac-0.4.4,1 >> libGL-7.0.3 >> libXext-1.0.3,1

===>>> Port directory: /usr/ports/x11/libXext
===>>> Gathering dependency list for x11/libXext from ports
===>>> Starting recursive 'make config' check
===>>> Launching child to update libXau-1.0.3_2 to libXau-1.0.4
   gpac-libgpac-0.4.4,1 >> libGL-7.0.3 >> libXext-1.0.3,1 >> libXau-1.0.3_2

===>>> Port directory: /usr/ports/x11/libXau
===>>> Gathering dependency list for x11/libXau from ports
===>>> Starting recursive 'make config' check
===>>> Launching child to update font-adobe-100dpi-1.0.0_1 to xproto-7.0.15
   gpac-libgpac-0.4.4,1 >> libGL-7.0.3 >> libXext-1.0.3,1 >> libXau-1.0.3_2 >> font-adobe-100dpi-1.0.0_1

   ===>>> No /usr/ports/Binary exists, and no information
   ===>>> about Binary can be found in /usr/ports/MOVED

===>>> No valid installed port, or port directory given
===>>> Try portmaster --help


===>>> Update for font-adobe-100dpi-1.0.0_1 failed
===>>> Aborting update

===>>> Update for libXau-1.0.3_2 failed
===>>> Aborting update

===>>> Update for libXext-1.0.3,1 failed
===>>> Aborting update

===>>> Update for libGL-7.0.3 failed
===>>> Aborting update

===>>> Update for gpac-libgpac-0.4.4,1 failed
===>>> Aborting update

Terminated
Terminated

i try to upgrade every single port but i find a new problem mostly .
SIFE
Member
 
Posts: 472
Joined: 02 Feb 2009, 20:00
Location: When ever where ever

Postby SirDice » 07 Oct 2009, 11:32

This doesn't look right:
Code: Select all
Launching child to update font-adobe-100dpi-1.0.0_1 to xproto-7.0.15


Odd as font-adobe-100dpi-1.0.0_1 is already up to date.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16185
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby SIFE » 27 Oct 2009, 15:23

i can't startx after upgrading gnome .
Code: Select all
waiting for X server to shut down FreeFontPath: FPE /usr/local/lib/X11/fonts/misc/ refcount is 2, should be 1; fixing.

if i start GDM i get my desktop GUI restart .
SIFE
Member
 
Posts: 472
Joined: 02 Feb 2009, 20:00
Location: When ever where ever

Postby SirDice » 27 Oct 2009, 15:50

SIFE wrote:
Code: Select all
waiting for X server to shut down FreeFontPath: FPE /usr/local/lib/X11/fonts/misc/ refcount is 2, should be 1; fixing.

You can ignore that message. I've been seeing the same one for ages and everything works.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16185
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby SIFE » 27 Oct 2009, 16:59

but i can't get X because the GDM daemon restart it self .
SIFE
Member
 
Posts: 472
Joined: 02 Feb 2009, 20:00
Location: When ever where ever

Postby SIFE » 04 Nov 2009, 09:06

after upgrading gnome this what i get :
Code: Select all
! devel/pcre (pcre-7.9)   (patch error)
! multimedia/xvid (xvid-1.1.3,1)   (patch error)
! multimedia/libdvdread (libdvdread-0.9.7_3)   (patch error)
! security/gnutls (gnutls-2.4.2_1)   (patch error)
! audio/libvorbis (libvorbis-1.2.0_2,3)   (patch error)
* sysutils/cdrdao (cdrdao-1.2.2)
! x11-fonts/libXfont (libXfont-1.3.1_3,1)   (patch error)
! textproc/libxslt (libxslt-1.1.24_1)   (patch error)
! graphics/jpeg (jpeg-6b_7)   (patch error)
* graphics/tiff (tiff-3.8.2_2)
! devel/popt (popt-1.7_5)   (patch error)
! graphics/libgphoto2 (libgphoto2-2.4.2_1)   (patch error)
* multimedia/libtheora (libtheora-1.0.b2)
! lang/perl5.8 (perl-5.8.8_1)   (patch error)
* devel/p5-Time-HiRes (p5-Time-HiRes-1.9715,1)
! security/libksba (libksba-1.0.3)   (patch error)
! audio/faad (faad2-2.6.1_1,1)   (patch error)
! ftp/curl (curl-7.18.0)   (patch error)
* textproc/p5-XML-NamespaceSupport (p5-XML-NamespaceSupport-1.09_1)
* devel/gamin (gamin-0.1.9_2)
* textproc/p5-XML-Parser (p5-XML-Parser-2.36)
* security/gnupg (gnupg-2.0.9_2)
* textproc/intltool (intltool-0.37.1)
* archivers/p5-Compress-Raw-Zlib (p5-Compress-Raw-Zlib-2.015)
* devel/gio-fam-backend (gio-fam-backend-2.16.5)
* accessibility/atk (atk-1.22.0_1)
* devel/libgtop (libgtop-2.22.3)
! security/nss (nss-3.11.9_2)   (patch error)
* devel/glibmm (glibmm-2.16.4,1)
* multimedia/libdvdnav (libdvdnav-0.1.10_3)
* devel/libIDL (libIDL-0.8.11)
* net/p5-URI (p5-URI-1.37)
* textproc/p5-XML-SAX-Writer (p5-XML-SAX-Writer-0.50)
* security/gpgme (gpgme-1.1.5_1)
* textproc/libxml++26 (libxml++-2.22.0_1)
* www/p5-HTML-Parser (p5-HTML-Parser-3.56_1)
* devel/ORBit2 (ORBit2-2.14.14)
* textproc/libcroco (libcroco-0.6.1_1)
* devel/py-gobject (py25-gobject-2.14.2_2)
* misc/shared-mime-info (shared-mime-info-0.51)
! graphics/cairo (cairo-1.6.4_2,1)   (patch error)
* www/p5-libwww (p5-libwww-5.814)
! graphics/dri (dri-7.0.3_1,2)   (patch error)
* x11-toolkits/pango (pango-1.20.5)
* x11-toolkits/vte (vte-0.16.14_1)
* graphics/py-cairo (py25-cairo-1.6.4)
* x11-toolkits/libwnck (libwnck-2.22.3)
* print/ghostscript8 (ghostscript8-8.62_5)
* print/libspectre (libspectre-0.2.1)
* devel/libglade2 (libglade2-2.6.3)
* devel/py-orbit (py25-orbit-2.14.3_1)
* graphics/libgnomecanvas (libgnomecanvas-2.20.1.1_2)
* x11/libxklavier (libxklavier-3.5_2,1)
! multimedia/gpac-libgpac (gpac-libgpac-0.4.4,1)   (install error)
* devel/dbus-glib (dbus-glib-0.76)
* net/avahi-app (avahi-app-0.6.23)
* textproc/enchant (enchant-1.4.0_1)
* x11-toolkits/py-gtk2 (py25-gtk-2.12.1_1)
* net/avahi-gtk (avahi-gtk-0.6.23)
* x11-toolkits/libsexy (libsexy-0.1.11_1)
* print/libgnomeprint (libgnomeprint-2.18.4_2)
* x11-toolkits/py-gtksourceview (py25-gtksourceview-2.2.0_1)
* devel/libnotify (libnotify-0.4.4_2)
* devel/libbonobo (libbonobo-2.22.0_1)
* accessibility/at-spi (at-spi-1.22.1_2)
* multimedia/x264 (x264-0.0.20080409_2)
* x11-toolkits/libgnomeprintui (libgnomeprintui-2.18.2_2)
* graphics/cairomm (cairomm-1.6.4)
* multimedia/gstreamer (gstreamer-0.10.20)
* multimedia/gstreamer-plugins (gstreamer-plugins-0.10.20_2,3)
* devel/gstreamer-plugins-gio (gstreamer-plugins-gio-0.10.20_2,3)
* x11/xscreensaver-gnome-hacks (xscreensaver-gnome-hacks-5.07)
* multimedia/gstreamer-plugins-bad (gstreamer-plugins-bad-0.10.8_1,3)
* multimedia/gstreamer-plugins-xvid (gstreamer-plugins-xvid-0.10.8_3,3)
* audio/gstreamer-plugins-cdparanoia (gstreamer-plugins-cdparanoia-0.10.20_1,3)
* multimedia/gstreamer-plugins-ugly (gstreamer-plugins-ugly-0.10.9_1,3)
* audio/gstreamer-plugins-a52dec (gstreamer-plugins-a52dec-0.10.9_3,3)
* audio/gstreamer-plugins-mad (gstreamer-plugins-mad-0.10.9_3,3)
* multimedia/gstreamer-plugins-good (gstreamer-plugins-good-0.10.10,3)
* audio/gstreamer-plugins-flac (gstreamer-plugins-flac-0.10.10_4,3)
* graphics/gstreamer-plugins-libpng (gstreamer-plugins-libpng-0.10.10_3,3)
* multimedia/gstreamer-plugins-dvd (gstreamer-plugins-dvd-0.10.9_3,3)
* multimedia/gstreamer-ffmpeg (gstreamer-ffmpeg-0.10.4_1)
* multimedia/ffmpeg (ffmpeg-2008.07.27_7)
* x11-toolkits/gstreamer-plugins-pango (gstreamer-plugins-pango-0.10.20_1,3)
* multimedia/gstreamer-plugins-mpeg2dec (gstreamer-plugins-mpeg2dec-0.10.9_3,3)
* multimedia/py-gstreamer (py25-gstreamer-0.10.12)
* multimedia/gstreamer-plugins-dts (gstreamer-plugins-dts-0.10.8_3,3)
* net/opal (opal-2.2.11)
* graphics/poppler (poppler-0.8.7)
* graphics/poppler-gtk (poppler-gtk-0.8.7)
* multimedia/gstreamer-plugins-theora (gstreamer-plugins-theora-0.10.20_1,3)
* audio/gstreamer-plugins-ogg (gstreamer-plugins-ogg-0.10.20_1,3)
* audio/gstreamer-plugins-vorbis (gstreamer-plugins-vorbis-0.10.20_1,3)
* net-im/telepathy-butterfly (py26-telepathy-butterfly-0.5.1)
* sysutils/policykit (policykit-0.9_1)
* sysutils/consolekit (consolekit-0.2.10_2)
* sysutils/system-tools-backends (system-tools-backends-2.6.0_1)
* x11/zenity (zenity-2.22.1_1)
* sysutils/hal (hal-0.5.11_1)
* devel/liboobs (liboobs-2.22.0_1)
* devel/gconf2 (gconf2-2.22.0_1)
* deskutils/gucharmap (gucharmap-2.22.3)
* devel/libgsf (libgsf-1.14.8_2)
* sysutils/gstreamer-plugins-hal (gstreamer-plugins-hal-0.10.10_4,3)
* devel/gstreamer-plugins-gconf (gstreamer-plugins-gconf-0.10.10_4,3)
* sysutils/policykit-gnome (policykit-gnome-0.9)
* x11-wm/metacity (metacity-2.22.0_2)
* math/gcalctool (gcalctool-5.22.3,2)
* deskutils/notification-daemon (notification-daemon-0.3.7_3)
* devel/libsoup (libsoup-2.4.1_1)
* devel/gstreamer-plugins-soup (gstreamer-plugins-soup-0.10.10_3,3)
* devel/gvfs (gvfs-0.2.5)
* graphics/swfdec (swfdec-0.6.8)
* multimedia/swfdec-gnome (swfdec-gnome-2.22.2_1)
* net/libgweather (libgweather-2.22.3)
* graphics/librsvg2 (librsvg2-2.22.2_2)
* x11/libgnome (libgnome-2.22.0_1)
* x11-toolkits/libbonoboui (libbonoboui-2.22.0_2)
* x11-toolkits/libgnomeui (libgnomeui-2.22.1_2)
* sysutils/gconf-editor (gconf-editor-2.22.0_2,1)
* databases/evolution-data-server (evolution-data-server-2.22.3_1)
* x11/libgnomekbd (libgnomekbd-2.22.0_2)
* accessibility/dasher (dasher-4.7.3_1,2)
* mail/evolution (evolution-2.22.3.1)
* mail/evolution-exchange (evolution-exchange-2.22.3)
* www/evolution-webcal (evolution-webcal-2.21.92_2)
* multimedia/totem-pl-parser (totem-pl-parser-2.22.3_1)
* x11-toolkits/py-gnome2 (py25-gnome-2.22.1)
* multimedia/cheese (cheese-2.22.3)
* x11-fm/nautilus (nautilus-2.22.5.1_1)
* graphics/evince (evince-2.22.2_3)
* audio/gstreamer-plugins-esound (gstreamer-plugins-esound-0.10.10_3,3)
* x11-toolkits/libgail-gnome (libgail-gnome-1.20.0_2)
* accessibility/gok (gok-1.3.7_2,1)
* net/vino (vino-2.22.2_2)
* archivers/file-roller (file-roller-2.22.4,1)
* audio/sound-juicer (sound-juicer-2.22.0_4)
* x11/yelp (yelp-2.22.1_1)
* devel/bug-buddy (bug-buddy-2.22.0_2)
* x11-toolkits/py-gnome-desktop (py25-gnome-desktop-2.22.0_1)
* net/vinagre (vinagre-0.5.1_2)
* accessibility/orca (orca-2.22.3)
* graphics/eog (eog-2.22.3)
* multimedia/totem (totem-2.22.2_2)
* net/ekiga (ekiga-2.0.11_4)
* deskutils/alacarte (alacarte-0.11.5_1)
* deskutils/deskbar-applet (deskbar-applet-2.22.3.1)
* www/epiphany (epiphany-2.22.3)
* editors/gedit (gedit-2.22.3_1)
* accessibility/mousetweaks (mousetweaks-2.22.3)
* security/seahorse (seahorse-2.22.3)

and when i type gdm i get :
Code: Select all
couldn't connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket:
No such file or directory .
SIFE
Member
 
Posts: 472
Joined: 02 Feb 2009, 20:00
Location: When ever where ever

Postby SirDice » 04 Nov 2009, 10:15

You might want to review that log. Everything with an ! failed. So I would be very surprised if it actually worked.

The error you are referring to means dbus isn't running. But as I said, I would fix the install errors first before moving on.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16185
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby SIFE » 04 Nov 2009, 16:38

so what do you suggest ?
SIFE
Member
 
Posts: 472
Joined: 02 Feb 2009, 20:00
Location: When ever where ever

Postby SirDice » 04 Nov 2009, 17:15

Start with [port]devel/pcre[/port]. I'm wondering why it (and quite a few others) are reporting patch errors.

Make sure your ports tree is up to date. Try and catch the full error. If we can figure that one out I'm sure the rest will be easy.
Senior UNIX Engineer at Unix Support Nederland
Experience is something you don't get until just after you need it.
User avatar
SirDice
Old Fart
 
Posts: 16185
Joined: 17 Nov 2008, 16:50
Location: Rotterdam, Netherlands

Postby SIFE » 05 Nov 2009, 15:52

i deinstall pcre and then install it from packages but the problem is steal with other packages like curl :
Code: Select all
--->  Upgrading 'curl-7.18.0' to 'curl-7.19.6_1' (ftp/curl)
--->  Building '/usr/ports/ftp/curl'
===>  Cleaning for curl-7.19.6_1
===>  Vulnerability check disabled, database not found
===>  Found saved configuration for curl-7.19.6_1
===>  Extracting for curl-7.19.6_1
=> MD5 Checksum OK for curl-7.19.6.tar.bz2.
=> SHA256 Checksum OK for curl-7.19.6.tar.bz2.
===>   curl-7.19.6_1 depends on file: /usr/local/bin/perl5.8.8 - found
===>  Patching for curl-7.19.6_1
===>   curl-7.19.6_1 depends on file: /usr/local/bin/perl5.8.8 - found
===>  Applying FreeBSD patches for curl-7.19.6_1
3 out of 3 hunks failed--saving rejects to configure.rej
=> Patch patch-configure failed to apply cleanly.
=> Patch(es) patch-Makefile.in applied cleanly.
*** Error code 1

Stop in /usr/ports/ftp/curl.
*** Error code 1

Stop in /usr/ports/ftp/curl.
   ! ftp/curl (curl-7.18.0)   (patch error)

SIFE
Member
 
Posts: 472
Joined: 02 Feb 2009, 20:00
Location: When ever where ever

Postby zeiz » 12 Nov 2009, 17:00

old enough thread... but instead of fighting with broken broken X installation I would go to single user mode and
Code: Select all
# ee /etc/rc.conf

comment out gnome_enable line and if I had gdm_enable line (instead of gnome_enable) I would check at once is there 2 lines required:
Code: Select all
dbus_enable="YES"
hald_enable="YES

Then I would reboot to console (without X) and
Code: Select all
# portsnap fetch update

Next step:
Code: Select all
# pkgdb -F

If everything is fine (or after fixing):
Code: Select all
# portupgrade -aP

Finally uncomment back gnome/gdm in rc.conf and reboot.
If same problems again I would delete all packages and then reinstall X and Gnome:
Code: Select all
# pkg_delete -df --all
# pkg_add portupgrade
# pkg_add xorg
# pkg_add gnome2
User avatar
zeiz
Member
 
Posts: 691
Joined: 19 Nov 2008, 18:36
Location: Canada

Postby SIFE » 14 Nov 2009, 17:43

Salamop Alikom
fanily i get my gnome with small problems that does not fix to now .
i found my ports was broken for that i get error "Applying FreeBSD patches error " so update again :
Code: Select all
portsnap fetch extract

then i fix the pkgdb :
Code: Select all
pkgdb -F

the default python version now is 26 so i unistall the old one and install the new one via packages :
Code: Select all
pkg_add -r python26

now i upgrade perl and theire depend it :
Code: Select all
portupgrade -rR "*perl*"

Code: Select all
portupgrade -rR "p5-"

then i upgrade python and theire depend it :
Code: Select all
portupgrade -rR "*py*"

Code: Select all
portupgrade -rR "*python*"

the i upgrade all library installed in my system :
Code: Select all
portupgrade -rR "lib*"

now upgrading X and depend it :
Code: Select all
portupgrade -rR '*xorg*'

finaly i upgrade gnome and all packages in the system :
Code: Select all
portupgrade -rR "*gnome*"

Code: Select all
portupgrade -arR

[color="Red"]NOTE :[/color]
i redirect outputs to file to catch packages fails to upgrade after that i deinstall it and then install it manually via ports or packages if that necessary .
audio-juicer i get this problem when i compile it from ports :
Code: Select all
/usr/local/lib/libcanberra.so: undefined reference to `strndup@FBSD_1.1'
gmake[2]: *** [sound-juicer] Error 1
gmake[2]: Leaving directory `/usr/ports/audio/sound-juicer/work/sound-juicer-2.26.1/src'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/audio/sound-juicer/work/sound-juicer-2.26.1'
gmake: *** [all] Error 2
*** Error code 1

Stop in /usr/ports/audio/sound-juicer.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portinstall20091112-8016-4radzh-0 env make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
   ! audio/sound-juicer   (linker error)
Command failed [exit code 1]: /usr/local/sbin/portinstall audio/sound-juicer

[color="Red"]problem still not fixed yet :[/color]
System Monitor does not work .
when i login to gnome i have to kill pulseaudio even after compiling kernel 7.2-STABLE .
if i run VirtualBox i get this :
Code: Select all
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/local/lib/virtualbox/VirtualBox.so",)
failed: /usr/local/lib/virtualbox/VBoxXPCOM.so: Undefined symbol "shmctl"

i get my GUI via startx not GDM .
SIFE
Member
 
Posts: 472
Joined: 02 Feb 2009, 20:00
Location: When ever where ever

Postby zeiz » 15 Nov 2009, 02:28

A lady came to a store and asked a salesperson for 30' long night-robe.
"Of course we can order such a piece for you but...why?" "You know, my husband is a scientist. For him research is important not the result".

What is your goal?
User avatar
zeiz
Member
 
Posts: 691
Joined: 19 Nov 2008, 18:36
Location: Canada

Postby dennylin93 » 15 Nov 2009, 06:21

SIFE wrote:.
if i run VirtualBox i get this :
Code: Select all
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/local/lib/virtualbox/VirtualBox.so",)
failed: /usr/local/lib/virtualbox/VBoxXPCOM.so: Undefined symbol "shmctl"



Perhaps this is related to something in [file]/usr/include/[/file]. Did you remove any header files?
dennylin93
Member
 
Posts: 784
Joined: 11 Dec 2008, 13:13

Postby SIFE » 15 Nov 2009, 06:46

no , i didn't .
SIFE
Member
 
Posts: 472
Joined: 02 Feb 2009, 20:00
Location: When ever where ever


Return to GNOME

Who is online

Users browsing this forum: No registered users and 0 guests